Idea 9: How to enable Tapestry facet ?

I have a project built with 5.0.18 Tapestry version with maven 2.
It's one of maven 2 sub projects. When I open parent pom Idea doesn't detects my Tapestry facet.
First I thought it could be because I had *.tml assosiated to 'Html files' file type, but then I manually switched it to 'Tapestry template file' in File->Settings->File types.
Still Tapestry facet isn't been detected.

When in 'Project structure'->Modules I select module of interest and click right mouse button I can't see Tapestry facet in New->...
But it is there in 'Project structure'->Facets and it has 'Enable auto-detection' switched on.

How can I fix Tapestry facet detection for my module ?

9 comments
Comment actions Permalink

Hello Konstantin,

The Tapestry facet depends on the Web facet. You'll be able to add the Tapestry
facet if you first add the Web facet.

I have a project built with 5.0.18 Tapestry version with maven 2.

It's one of maven 2 sub projects. When I open parent pom Idea doesn't
detects my Tapestry facet.

First I thought it could be because I had *.tml assosiated to 'Html
files' file type, but then I manually switched it to 'Tapestry
template file' in File->Settings->File types.

Still Tapestry facet isn't been detected.

When in 'Project structure'->Modules I select module of interest and
click right mouse button I can't see Tapestry facet in New->...

But it is there in 'Project structure'->Facets and it has 'Enable
auto-detection' switched on.

How can I fix Tapestry facet detection for my module ?


--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Konstantin Miklevskiy wrote:

I have a project built with 5.0.18 Tapestry version with maven 2.
It's one of maven 2 sub projects. When I open parent pom Idea doesn't detects my Tapestry facet.
First I thought it could be because I had *.tml assosiated to 'Html files' file type, but then I manually switched it to 'Tapestry template file' in File->Settings->File types.
Still Tapestry facet isn't been detected.

When in 'Project structure'->Modules I select module of interest and click right mouse button I can't see Tapestry facet in New->...
But it is there in 'Project structure'->Facets and it has 'Enable auto-detection' switched on.

How can I fix Tapestry facet detection for my module ?

---
Original message URL: http://www.jetbrains.net/devnet/message/5241493#5241493

Hi Konstantin,

Does the module have Web facet?
Tapestry facet relies on Web facet and is detected by presence of
reference to org.apache.tapestry5.TapestryFilter class in web.xml
descriptor file.

0
Comment actions Permalink

I predicted that, but I already have 'Web' facet on that module see attached screenshot.

Just tried to create Tapestry enabled sample project from ground up and it started with Tapestry facet.
Could it be version diff ? When creating new project using wizard it uses 5.1.0.5 and I use version 5.0.18



Attachment(s):
NoTapestryFacet.png
0
Comment actions Permalink

Konstantin,

create, please, jira issue.

Konstantin Miklevskiy wrote:

I predicted that, but I already have 'Web' facet on that module see attached screenshot.

Just tried to create Tapestry enabled sample project from ground up and it started with Tapestry facet.
Could it be version diff ? When creating new project using wizard it uses 5.1.0.5 and I use version 5.0.18

---
Original message URL: http://www.jetbrains.net/devnet/message/5241501#5241501


------------------------------------------------------------------------

0
Comment actions Permalink

Did you try to select 'Web' facet node and press '+' button?

I predicted that, but I already have 'Web' facet on that module see attached screenshot.

Just tried to create Tapestry enabled sample project from ground up and it started with Tapestry facet.
Could it be version diff ? When creating new project using wizard it uses 5.1.0.5 and I use version 5.0.18

---
Original message URL: http://www.jetbrains.net/devnet/message/5241501#5241501


------------------------------------------------------------------------



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Here's what I have in web.xml:

    <filter-class>org.apache.tapestry5.spring.TapestrySpringFilter</filter-class>


Changed that to:

    <filter-class>org.apache.tapestry5.TapestryFilter</filter-class>


But still Tapestry facet isn't been autodetected (reopened IDE to be sure) and I can't explicitly add it to modure.


0
Comment actions Permalink

Still have same problems with tapesry facet.
Idea#10781+  Widows 7 + tapestry 5.1.0.5+ spring 2.5.6 (optional +maven 2)

How to solve the problem?

0
Comment actions Permalink

i have solved the problem:
change extension association from XHTML to Tapestry

0

Please sign in to leave a comment.