Maven 2.1.x and 2.2.x support

We have maven projects where we set the prerequisites/maven to 2.1.0 or 2.2.0. However, the built in maven support shows an error for these projects - even when I have overriden the maven home location to point to a 2.1.0 or 2.2.0 installation.

Will Intellij support 2.1.x and 2.2.x versions of Maven?

4 comments
Comment actions Permalink

Hi, Alex,

I try to add the support in one of next eaps of 9.0.

Thanks,
Anton Makeev

0
Comment actions Permalink

Jira ticket for tracking:
http://www.jetbrains.net/jira/browse/IDEA-23974

How difficult will it be to backport it into 8.x ?

0
Comment actions Permalink

The problem with these versions is that they do not have embedding capabilities - thay was dropped. I cannot tell you for sure when I manage to bundle them with 9.0, and it doesn't seem reasonable to backport these change to 8.0 since it will change behaviour drammatically and will take time to stabilize (probably till the release of 9.0).

What features of 2.2 do you find useful for your team?

0
Comment actions Permalink

We use the new 'prepare-package' phase, for example.

0

Please sign in to leave a comment.