Anyone else have issues with Navigation History?

For me Navigation History has been broken since build 9013 (EAP release of IntelliJ 8) and remains broken in IntelliJ 8.1.3. This affects all members of my team who use IntelliJ. By broken I mean it jumps to random files and even to files outside of the current project (with both the toolbar nav. history button and ctrl-alt-left/right arrow).

There is a issue open for it: http://www.jetbrains.net/jira/browse/IDEA-20496 but Jetbrains seems to have forgotten about it. I have made many comments in that issue trying to give as much info as I possibly can but to no avail.

Does anyone else have this problem? If it affected everyone I am sure there would be a lot of complaints but I don't see a lot of complaints about it so I can only assume it doesn't affect everyone.

If it doesn't affect many people what could be the reason it affects me? Some magical combination of my settings?

It has affected me on both Ubuntu 8.04-8.10 and Mac OS X 10.5.x. Including on a brand new machine that I installed IntelliJ on.

2 comments
Comment actions Permalink

Michael Parmeley wrote:

For me Navigation History has been broken since build 9013 (EAP release of IntelliJ 8) and remains broken in IntelliJ 8.1.3. This affects all members of my team who use IntelliJ. By broken I mean it jumps to random files and even to files outside of the current project (with both the toolbar nav. hi
story button and ctrl-alt-left/right arrow).

There is a issue open for it: http://www.jetbrains.net/jira/browse/IDEA-20496 but Jetbrains seems to have forgotten about it. I have made many comments in that issue trying to give as much info as I possibly can but to no avail.

Does anyone else have this problem? If it affected everyone I am sure there would be a lot of complaints but I don't see a lot of complaints about it so I can only assume it doesn't affect everyone.

If it doesn't affect many people what could be the reason it affects me? Some magical combination of my settings?

It has affected me on both Ubuntu 8.04-8.10 and Mac OS X 10.5.x. Including on a brand new machine that I installed IntelliJ on.

---
Original message URL: http://www.jetbrains.net/devnet/message/5241094#5241094

I don't suppose you use a single tab or no tabs? There have been
problems with that and navigation for ages.
N.

0
Comment actions Permalink

Prior to build 9013 I used a single-tab. Once I saw that IntelliJ 8.x supported using no tabs I turned that on. However, the navigation history problem has forced me to turn tabs back on as that helps mitigate the nav. history problem (using tabs, ctrl-e, and ctrl-n makes the nav. history problem only highly annoying rather than detrimental).

So when I first installed IntelliJ 8.x I did turn tabs off, but I have since turned them back on. Since turning tabs off was the very first thing I did I am unsure if that is when my problems started. However, I have installed IntelliJ freshly on a new machine without ever turning tabs off and I still have the same problem.

0

Please sign in to leave a comment.