how to prevent idea from string temp files in c:\users....

i copied all my projects, jdks and ideas to a ssd and reconfigured everything to read and write everything to the ssd so i can simple take it, connect it to another computer and continue working there. however, i noticed idea writes temp files to the user directory ("whatever:/...appdata/local/tempdir/webexploded...")
in my case, this drive was completely full so idea failed.
is there a way to force idea to use a specific temp directory?

1 comment
Comment actions Permalink

Just a guess: Try adding this to IDEA's startup options (idea.exe.vmoptions):
-Djava.io.tmpdir=]]>

HamsterofDeath wrote:

i copied all my projects, jdks and ideas to a ssd and reconfigured everything to read and write everything to the ssd so i can simple take it, connect it to another computer and continue working there. however, i noticed idea writes temp files to the user directory ("whatever:/...appdata/local/tempd
ir/webexploded...")
in my case, this drive was completely full so idea failed.
is there a way to force idea to use a specific temp directory?

---
Original message URL: http://www.jetbrains.net/devnet/message/5240057#5240057

0

Please sign in to leave a comment.