11 comments
Comment actions Permalink

By the way:

Taskdef doesn´t work properly. It produces "red code":

]]>

<schemaexport
^^^
this is red :(

0
Comment actions Permalink

Taskdef has been like that for me since 3.0, I don't think it has ever worked.

0
Comment actions Permalink

+1 from a heavy ant user.

I haven't tried 1.6 yet, but anticipate using it in the next few months.

This reminds me of the feature request to be able to switch between different ant versions per project similar to how we can select the JDK.

I will definately be in the situation where one project is still using 1.5 and the new project is using 1.6.

0
Comment actions Permalink

I would like to know as well. Our project is using Ant 1.5 at the moment
and we're going to try updating to Ant 1.6 sometime soonish since it
will allow us to reduce the size and complexity of our build file
substantially.

Please consider changing IDEA 4 to use Ant 1.6 or provide the ability to
use a user-installed version of Ant
(http://www.intellij.net/tracker/idea/viewSCR?publicId=9639)

Thanks,
Gordon

--
Gordon Tyler (Software Developer)
Quest Software <http://java.quest.com/>
260 King Street East, Toronto, Ontario M5A 4L5, Canada
Voice: 416-643-4846 | Fax: 416-594-1919

0
Comment actions Permalink

We've been using Ant 1.6 since it went beta (late Sept?). Ant 1.6 is great. We use it for builds and tests, and find that it is faster, more elegant, and simplifies builds with the new functionality.

We just assumed that it would be included in IDEA 4 (it is the company ide), and have been waiting for it.

It would be a shame if it isn't added. It is real annoying to have to go to a shell to run Ant when one of the reasons we went with IDEA is that it had built-in Ant support.

I just added it as a feature request in EAP Tracker. Please go there and vote if you feel that you would like to see this happen.

0
Comment actions Permalink

what's your defect URL?

"Pat Cousineau" <pcousineau@upromise.com> wrote in message
news:23905671.1072825301531.JavaMail.itn@is.intellij.net...

We've been using Ant 1.6 since it went beta (late Sept?). Ant 1.6 is

great. We use it for builds and tests, and find that it is faster, more
elegant, and simplifies builds with the new functionality.
>

We just assumed that it would be included in IDEA 4 (it is the company

ide), and have been waiting for it.
>

It would be a shame if it isn't added. It is real annoying to have to go

to a shell to run Ant when one of the reasons we went with IDEA is that it
had built-in Ant support.
>

I just added it as a feature request in EAP Tracker. Please go there and

vote if you feel that you would like to see this happen.


0
Comment actions Permalink

Sorry. The url is:

http://www.intellij.net/tracker/idea/viewSCR?publicId=25118

This is asking specifically for 1.6 support (since it has now gone gold) as different from pointing to a user version. I'm assuming (perhaps incorrectly) that this would be a bit easier? Pointing to a user version would be much more flexible.

0
Comment actions Permalink

Even if Aurora doesn't come with it now, knowing JetBrains they will
probably release a 4.0.1 or something with it as soon as it comes out.

"Pat Cousineau" <pcousineau@upromise.com> wrote in message
news:32463416.1072827599559.JavaMail.itn@is.intellij.net...

Sorry. The url is:

>

http://www.intellij.net/tracker/idea/viewSCR?publicId=25118

>

This is asking specifically for 1.6 support (since it has now gone gold)

as different from pointing to a user version. I'm assuming (perhaps
incorrectly) that this would be a bit easier? Pointing to a user version
would be much more flexible.
>
>


0
Comment actions Permalink

Are there any examples of how to rework an earlier build file to use these new features? I looked briefly at the 1.6 release notes, and skimmed the new tasks, but it's not immediately clear to me how to take full advantage of them.

0
Comment actions Permalink

I recommend voting for:
http://www.intellij.net/tracker/idea/viewSCR?publicId=19465
instead.

Even though it was originally asking for ant 1.6-beta support, it
has been prioritized as "very high" and already has a good deal
of votes. It is always possible to add comments to it to help
point out that Ant 1.6 is final.

Vince.

"Pat Cousineau" <pcousineau@upromise.com> wrote in message
news:32463416.1072827599559.JavaMail.itn@is.intellij.net...

Sorry. The url is:

>

http://www.intellij.net/tracker/idea/viewSCR?publicId=25118

>

This is asking specifically for 1.6 support (since it has now gone gold)

as different from pointing to a user version. I'm assuming (perhaps
incorrectly) that this would be a bit easier? Pointing to a user version
would be much more flexible.
>
>


0

Please sign in to leave a comment.