Weblogic 8.1 Support

I am running a weblogic 8.1 server locally and I configured weblogic server instance in IntelliJ and I can start/stop weblogic from with in IntelliJ. However when I click on the debug icon, nothing happens. I have to click on the run icon to start weblogic. But the control doesn't stop at the breakpoints while running the application and clicking on debug does nothing. Wondering if anybody has faced similar problem ?

7 comments
Comment actions Permalink

Hello,

dumb question.... You have started WebLogic in debug mode?

I am using the exact same setup and have been able to debug JSPs and Servlets with no problem.

See if this thread helps:
http://www.intellij.net/forums/thread.jsp?forum=4&thread=32560&message=499925&q=7765626c6f676963#499925

John

0
Comment actions Permalink

well... I can already remote debug an application using weblogic server. However, I am not able to debug an application using integrated weblogic instance debugger. I would prefer using an integrated debugging over remote debugging so that I can set breakpoints in JSP. I tried running Weblogic server in both debug and non-debug mode, but nothing helps.

any idea?

0
Comment actions Permalink

Sorry,

you are correct. I haven't been able to debug JSP's, only servlets.

John

0
Comment actions Permalink

It's the bug that will be fixed in the next build

--
regards,
Alexey Kudravtsev.
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"


"q" <no_mail@jetbrains.com> wrote in message news:9620445.1070242110990.JavaMail.javamailuser@localhost...

I am running a weblogic 8.1 server locally and I configured weblogic server instance in IntelliJ and I can start/stop weblogic

from with in IntelliJ. However when I click on the debug icon, nothing happens. I have to click on the run icon to start weblogic.
But the control doesn't stop at the breakpoints while running the application and clicking on debug does nothing. Wondering if
anybody has faced similar problem ?


0
Comment actions Permalink

Oh!!!. Eagerly waiting for the bug fix.

0
Comment actions Permalink

Any word on this issue from IntelliJ.

0
Comment actions Permalink

The bug was fixed in build 1014 AFAIR

--
regards,
Alexey Kudravtsev
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


"q" <no_mail@jetbrains.com> wrote in message news:7906125.1071939332939.JavaMail.itn@is.intellij.net...

Any word on this issue from IntelliJ.



0

Please sign in to leave a comment.