Flex Facet fails to pick up 10.0.0 Flash types

Hi all,
I'm using the Flex Facet, and here is my problem:

Any 10.0.0 flash type, such as Vector or flash.text.engine are marked as unknown in the code editor.   I can, however, compile with these 10.0.0 types by configuring the mxmlc compiler with target-player=10.0.0... but I can't figure out how I get intellij to discover types specific to Flash 10 for code completion and so on.

Thanks for any help!

Regards,
Seth

10 comments
Comment actions Permalink

Hi
In Flex SDK settings please replace reference to ... 9/playerglobal.swc
with ... 10/playerglobal.swc

Seth Call wrote:

Hi all,
I'm using the Flex Facet, and here is my problem:

Any 10.0.0 flash type, such as Vector or flash.text.engine are marked as unknown in the code editor. I can, however, compile with these 10.0.0 types by configuring the mxmlc compiler with target-player=10.0.0... but I can't figure out how I get intellij to discover types specific to Flash 10 for c
ode completion and so on.

Thanks for any help!

Regards,
Seth

---
Original message URL: http://www.jetbrains.net/devnet/message/5235952#5235952



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

Hey Maxim,

Thanks for the help.  I'm not sure I'm 100% certain what you mean, but this is my best guess:

I've configured Intellij Flex Facet to reference a custom flex-config.xml.   In that file, I have the following configuration:

      <external-library-path>
          <path-element>/path/to/flex_sdk_3/frameworks/libs/player/10/playerglobal.swc</path-element>

      </external-library-path>

(also, I have this:)

         <target-player>10.0.0</target-player>


Also, I tried changing the global SDK flex-config.xml to match these two values, in conjuction with the project flex-config.xml to rule out any issues there, restarted intellij, and still no luck.

By the way, I'm using Diana Build #9805 because of some other improvements added to the Flex facet (such as http://www.jetbrains.net/jira/browse/IDEA-22329)

Am I doing what you wanted me to try?

Thanks!
Seth

0
Comment actions Permalink

IDEA has its own Flex SDK definition (in project settings), and you need
to change referenced swc in that place

Seth Call wrote:

Hey Maxim,

Thanks for the help. I'm not sure I'm 100% certain what you mean, but this is my best guess:

I've configured Intellij Flex Facet to reference a custom flex-config.xml. In that file, I have the following configuration:

<external-library-path>
<path-element>/path/to/flex_sdk_3/frameworks/libs/player/10/playerglobal.swc</path-element>

</external-library-path>

(also, I have this:)

<target-player>10.0.0</target-player>


Also, I tried changing the global SDK flex-config.xml to match these two values, in conjuction with the project flex-config.xml to rule out any issues there, restarted intellij, and still no luck.

By the way, I'm using Diana Build #9805 because of some other improvements added to the Flex facet (such as http://www.jetbrains.net/jira/browse/IDEA-22329)

Am I doing what you wanted me to try?

Thanks!
Seth

---
Original message URL: http://www.jetbrains.net/devnet/message/5235959#5235959



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

I hate to ask but... where are these settings more specifically?

I've checked in Preferences > Project Settings, and see nothing related to flex (ss below scaled down quite a bit for the forum).  I expanded every option there... found nothing.

Picture 8.png
The closest thing I've seen is the 'Framework Support' settings when I right-click on my project module in the 'Project' docked window, which let's me choose only the Flex SDK path, as shown here:

Picture 7.png

Maybe the latest Diana build doesn't let you specify this?  Check out this screen shot on that bug I referenced earlier: http://www.jetbrains.net/jira/browse/IDEA-22329

http://www.jetbrains.net/jira/secure/attachment/28951/Picture+10.png

Mine doesn't look like that... here's mine:
Picture 9.png

Thanks again,
Seth

0
Comment actions Permalink

So, ok... I agree it's hard to set it in Intellij (and so i did vote)... but in my case, I don't see how one can get this to work at all in intellij at the moment.  At least, with this latest build...

Thanks,
Seth

0
Comment actions Permalink

Expand JDKs in platform settings category. You might need to recreate
FlexSDK library attached to project.

Seth Call wrote:

So, ok... I agree it's hard to set it in Intellij (and so i did vote)... but in my case, I don't see how one can get this to work at all in intellij at the moment. At least, with this latest build...

Thanks,
Seth

---
Original message URL: http://www.jetbrains.net/devnet/message/5235976#5235976



--
Best regards,
Maxim Mossienko
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

Hey Maxim,

Thanks, that fixed it! I will say, though, that it wasn't very easy... here's why:

  1. I tried to just change from /9/playerglobal.swc to /10/playerglobal.swc of the existing Flex SDK--the type still couldn't be found
  2. I removed the existing Flex SDK, re-added it, fixed 9 to 10. didn't change anything.
  3. I have a second Flex SDK installed on my filesystem, as luck would have it.  So, I added it to the list of JDKs, and once I hit apply on that, something kicked in and then the 10.x types could be found.



Seth

0
Comment actions Permalink

Indeed, changing the SDK does not seem to force a "reparse".
I've seen that a few times as well.

-tt

0
Comment actions Permalink

Taras Tielkes wrote:

Indeed, changing the SDK does not seem to force a "reparse".
I've seen that a few times as well.


I've added an issue for that
http://www.jetbrains.net/jira/browse/IDEADEV-36283

0

Please sign in to leave a comment.