ipr and iml files visible in project view

Hi,
On version 7, I can see the .ipr and .iml files are visible in project view. This behavior was not there in previous versions. My ipr and and iml files are in one directory and source files/content roots are in different directory. Is this behavior expected or my settings are not correct. I do not want to see iml and ipr files in my project view. Attached is the file.



Attachment(s):
idea.GIF
4 comments
Comment actions Permalink

Hello Ashwani,

Yes, this behavior is expected and your settings are correct. There is no
way to configure this.

Hi, On version 7, I can see the .ipr and .iml files are visible in
project view. This behavior was not there in previous versions. My ipr
and and iml files are in one directory and source files/content roots
are in different directory. Is this behavior expected or my settings
are not correct. I do not want to see iml and ipr files in my project
view. Attached is the file.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Is there any way to avoid this behavior? I have all my project files in one folder and since i upgraded from 6 to 8 I have em all in my project view. Kinda odd...

Thanks,
Tino

0
Comment actions Permalink

Hello tino,

Is there any way to avoid this behavior? I have all my project files
in one folder and since i upgraded from 6 to 8 I have em all in my
project view. Kinda odd...


As replied in the previous message, no, there is no way to avoid this behavior.
Is there any real inconvenience from having these files visible, other than
it being odd?

(The reason why we show them is, for example, so that you would be able to
perform VCS operations on them.)

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

There's a way to get rid of them.
You can append "*.iml;*.iws;*.ipr;" (without quotes) to "Settings > File Types > Ignore files and folders".

0

Please sign in to leave a comment.