Launching IDEA in Gnome

Hi,

Sorry if I choose wrong forum - I first time here.

Could anybody launch IDEA in Gnome without console?

Thanks to Serge Baranov, he helped me to change idea.sh and add nohup and & to it.

So now I have created new file inside /usr/local/bin and I can launch idea simply typing "idea" in my terminal:

z@z-laptop:~$ idea
nohup: appending output to `nohup.out'
z@z-laptop:~$

Then I just close terminal and everything is find.

What I did is changed idea.sh. I replaced:

exec $IDEA_JDK/bin/java $JVM_ARGS $IDEA_MAIN_CLASS_NAME $*

with

exec nohup $IDEA_JDK/bin/java $JVM_ARGS $IDEA_MAIN_CLASS_NAME $* &

But if I press Alt+F2 and type idea - I got nothing. No errors, just nothing.

Maybe someone has already did it and found the solution?

5 comments
Comment actions Permalink

I have never tried launching it from the alt-f2 dialog but it launches fine from a menu item.

It also launches fine using Gnome Do (like Quicksilver on the Mac). http://do.davebsd.com/

Screenshot-Launcher Properties.png

0
Comment actions Permalink

Hi Michael,

Yes, I tried this, but it doesn't work, that is why I'm asking..

Any way, thanks for gnome-do!

It's really cool! Was playing with it about 3 hours... nice...

0
Comment actions Permalink

I was wondering how to do this as well. I found a page that suggested using the following

/bin/bash -c "export IDEA_JDK=/opt/java1.6 && /home/rod/opt/idea-7.0.4/bin/idea.sh"

and the following also works

/bin/bash -c "IDEA_JDK=/opt/java1.6 /home/rod/opt/idea-7.0.4/bin/idea.sh"

0
Comment actions Permalink

I don't recall having to make any changes to get idea to run from a menu item. I do have JDK_HOME set in /etc/environment. Maybe that is why it worked.

Remember the GUI (in this case GNOME) doesn't get the environment variables of the logged in user. You have to have the appropriate environment variables set globally. In Ubuntu that is /etc/environment.

0
Comment actions Permalink

Man, thanks......

I'm lamer..

I've set JDK_HOME into my .bashrc & trying to launch it without bash, so stupid.....

Thanks a lot for /etc/environment, now everything works perfect.

0

Please sign in to leave a comment.