"Tag pair" live template - by default, doesn't work in "Java comment" context


Subj.

For me it just stopped working - when writing a javadoc I type '>' where '|' is my cursor. Now I see that this live template (sitting in html/xml group) doesn't have "Java comment" checked in it's applicable contexts. After checking this option - everything is works as expected. My question is - what was a rationale for removing this option by default ? Just a mistake or something else ? "Tag pair" template is very useful in Javadoc when dropping some HTML tags like ]]>, for example ..

2 comments

I think this option was simply neglected when creating the template.
I have corrected the defaults for this template.

Friendly,
Eugene.

"Evgeny Goldin" <no_mail@jetbrains.com> wrote in message
news:13279103.1070793325736.JavaMail.javamailuser@localhost...
>

Subj.

>

For me it just stopped working - when writing a javadoc I type '<', press

Tab and nothing happens, although I expected it to be '<|></>' where '|' is
my cursor.
>

Now I see that this live template (sitting in html/xml group) doesn't have

"Java comment" checked in it's applicable contexts. After checking this
option - everything is works as expected.
>

My question is - what was a rationale for removing this option by default

? Just a mistake or something else ?

"Tag pair" template is very useful in Javadoc when dropping some HTML tags

like ]]>, for example ..


0

This fix broke an interesting scenario:

1. In a Java comment

2. Type "Please don't "

Actual: on hitting space after the 't', live templates inserts the html tags

Expect: don't do that :)

0

Please sign in to leave a comment.