IDEA does not find source while debugging

When debugging my project's struts web app using
the remote debugging option, IDEA does not find the struts source when stepping through the code
although I've attached the source to my definition
of the struts project library.
The library points to the jar, which is in one spot, and the attached source points to a different location, which is outside any path defined otherwise for the project.
To illustrate:




So the library definition has struts jar from \dev\proj\thirdparty\struts.jar
and the attached source is from \dev2\struts-src\src.

The only way for me to see the struts source is if I add it as a content folder, which I'm reluctant to do.

Any idea how I can solve this?

Bonny

3 comments

please submit a request in tracker.
it would be also greate if you do the following:
1.remove dev2 from your project
2.attach to web app
3.step into the class from this library
4.press Ctrl+N and fill in the name of that class,
of cource check Include non-project classes

what list of classes does IDEA provide? are there only decompiled classes or sources either?

0

I'm not sure I understand what you want me to do:

dev2 is not part of the project, it is only associated with the project as an attached source directory to one
of the project libraries (i.e. struts).
My previous illustration was a bit off, so I'll illustrate it again. I don't think this would make a difference, though.



My current project configuration contains the 'proj' as the single content entry and all the 'src' directories
under each component are listed as source folders.

Under the libraries pane, in a project library I called 'struts', I have the 'proj/thirdparty/struts.jar' as the content
of the 'classes' subfolder and the 'source' folder
contains the path '/dev2/struts-src/src'.


As for the debugging, if the source for struts is attached or not, when stepping through the code and
looking up a class, I get the decompiled version every time which is preceisely what the problem symptom is.

The only way I can see the source is if I add the struts
source as a separate content entry to the project. But IDEA slows right down when I do this and becomes unresponsive every 30 seconds or so or every time I change the focus from the IDEA window to any other application window.

Cheers,

Bonny

0

If struts is not under content root you have problem with debugger.

I'm trying to find out whether there are problems in other subsystems, or it's debugger bug.

If you open library classes with Goto Class... (Ctrl+N) do you see sources or decompiled version?

0

Please sign in to leave a comment.