Problem with Tomcat debug mode

In Version 7 there was no problem, after upgrading to Version 8 (today) I get so following Message, when I start Tomcat in Debug-Mode:

....
Using CATALINA_HOME: C:\tomcat5
Using CATALINA_TMPDIR: C:\tomcat5\temp
Using JAVA_HOME: C:\java\1.4.2_18
JDWP unable to access JVMDI Version 1.
Maybe you need to start the VM with the -Xdebug option
Error occurred during initialization of VM
-Xrun library failed to init: jdwp
Disconnected from server

If I run Tomcat as normal (run) everthing is fine. The debug java opts (which I cannot modify) are: -Xrunjdwp:transport:dt_socket,adress=127.0.0.1:3417,suspend=y,server=n

With share memory debugging I get the message...

Using CATALINA_HOME: C:\tomcat5
Using CATALINA_TMPDIR: C:\tomcat5\temp
Using JAVA_HOME: C:\java\1.4.2_18
Error occurred during initialization of VM
-Xrun library failed to init: jdwp
JDWP unable to access JVMDI Version 1.
Maybe you need to start the VM with the -Xdebug option
Disconnected from server

Someone hast any suggestion for me ?

Regards

Jürgen

4 comments
Comment actions Permalink

So I've got Tomcat working if I add a additional line in Startup/Connection->Debug->Environment variables:

JAVA_OPTS -Xdebug

So where is this option gone ? In Version 7 it was in my standard Installation. I even cannot edit this -Xrunjdwp:.... line.

Regards

Jürgen

0
Comment actions Permalink

So okay,

tomcat starts, but no breakpoint will work. So there is something other wrong. I have no idea whats wrong. and have to use version for development.

0
Comment actions Permalink

Intellij Support helped me by answering via email: The problem is jdk1.4 won't work any more with idea 8 und tomcat debug. It must be > jdk 1.5.

0
Comment actions Permalink

Problem is solved in Version 8.0.1

0

Please sign in to leave a comment.