Idea and Tomcat 6 (and 5.5.27 also) - Port already in use

Hello there,
I`m a newbie in Idea and trying to make JSP application using Apache Tomcat server.
I`ve been looking already about my problem but no solution was right for me, so I`m starting a new discussion:
I`ve got fresh instalation of Idea 8, Apache Tomcat 5.5.27 (already tried 6) in standalone mode not as a service.
No application is using port 8080, everything looks nice, but when running app a message window with message: "Port is already in use" displays.
I`m using Eset Smart Security as firewall and antivirus and it`s disabled during run.
I don`t know where is the problem, I`ve tried almost everything I found on the net. Please help if you know
And nice Christmas!

2 comments
Comment actions Permalink

hi,

you two different ways

add a remote configuration to idea -> ->
-> =>

or

add a local configuration to idea but your local tomcat must be offline.
idea will start him as needed...

marecek developer schrieb:

Hello there,
I`m a newbie in Idea and trying to make JSP application using Apache Tomcat server.
I`ve been looking already about my problem but no solution was right for me, so I`m starting a new discussion:
I`ve got fresh instalation of Idea 8, Apache Tomcat 5.5.27 (already tried 6) in standalone mode not as a service.
No application is using port 8080, everything looks nice, but when running app a message window with message: "Port is already in use" displays.
I`m using Eset Smart Security as firewall and antivirus and it`s disabled during run.
I don`t know where is the problem, I`ve tried almost everything I found on the net. Please help if you know
And nice Christmas!

>

---
Original message URL: http://www.jetbrains.net/devnet/message/5229528#5229528

0
Comment actions Permalink

hi!
Thanks for help, the problem was that I`ve had selected Local server.
Configuration I`m running now is: Tomcat 6 as service and Remote server in Idea project configuration.

0

Please sign in to leave a comment.