977: AntiAliasing for IDE doesn't work

I'm clicking the checkbox for 'Use antialiased font in IDE windows' but for some reason it isn't working anymore in this build. The editor antialiasing seems to be working however. This is one of my favorite features!

7 comments

I've found that it has somethign to do with using 1.4.2_02, if you use 1.4.2_01 the anti-aliasing works.

0

It seems that you use standard JRE instead of IDEA bundled JRE.
I have the same, but then i swithed to inline IDEA JRE, the antialising is
work fine.

Thanks!

"billwhitelogin" <no_mail@jetbrains.com> wrote in message
news:18073339.1068841078641.JavaMail.itn@is.intellij.net...

I'm clicking the checkbox for 'Use antialiased font in IDE windows' but

for some reason it isn't working anymore in this build. The editor
antialiasing seems to be working however. This is one of my favorite
features!


0

Well, I'm not so sure about that since I downloaded and installed the 977 bundle that contained the 1.4.2_02 JRE (i.e. I'm using the 'inline' JRE that you suggest) and I don't get anti-aliasing in the IDE. However, like the original poster, the font in the editor window is anti-aliased.

Maybe it's a Windows vs Linux problem, I'm using Mandrake 9.2 and KDE 3.1.4.

I'd forgotten how ugly everything looked when we didn't have anti-aliasing.

0

Well, like I said. If you run with the bundled 857 JRE which is 1.4.2_01 or any 1.4.2_01 JRE, anti-aliasing works

0

I've tried copying the the 1.4.2_01 JRE in place of the 1.4.2_02 JRE that comes with build 977 (including the copying of the tools.jar to jre/lib and copying javac.exe to jre/bin) and when I start Intellij, it says that it will only work with 1.4.2_02. How did you get 977 to run with 1.4.2_01?

0

add -Didea.no.jdk.check=true to your jvm options

0

Please sign in to leave a comment.