977 Linux: double-clicking a variable name doesn't select it properly

Hi,

Not sure if this has been posted before but it's an annoying bug that's
preventing me from using 977 for real work. If you have a variable name
(e.g. myVar) and in the editor double-click on it, only the 'my' part of
it will be selected. The only way to select a variable like this seems
to be to manually drag the mouse over its entirety. Variables without a
middle capital letter seem to work fine though (e.g. myvar).

Thanks,

Nick.

1 comment

Nick Atkins wrote:

Not sure if this has been posted before but it's an annoying bug that's
preventing me from using 977 for real work. If you have a variable name
(e.g. myVar) and in the editor double-click on it, only the 'my' part of
it will be selected. The only way to select a variable like this seems
to be to manually drag the mouse over its entirety. Variables without a
middle capital letter seem to work fine though (e.g. myvar).


That sounds like the CamelHumps option has been turned on. Look in
Options->IDE Settings->Editor on the right under "Smart Keys", the last
option should be Use "CamelHumps" words.

Ciao,
Gordon

--
Gordon Tyler (Software Developer)
Quest Software <http://java.quest.com/>
260 King Street East, Toronto, Ontario M5A 4L5, Canada
Voice: 416-643-4846 | Fax: 416-594-1919

0

Please sign in to leave a comment.