Subversion problems

Hi,

I just started to use IntelliJ with subversion and I have a problem with IntelliJ's proxy usage.
My IntelliJ is set up with a HTTP proxy for plugin downloads. Our proxy does not support the WebDAV commands like PROPFIND. But my SVN repo is local so after some digging I found that.

- IntelliJ can be instructed to bypass the http-proxy for SVN operations by un-checking "Use idea proxy as Default" in  "Settings->VersionControl->Configure VCS..."

After doing this I can successfully browse my SVN repo without problems.

Then I did the following:

- Checked out code from SVN using command line SVN client  (code includes IntelliJ project and module files)

- Enabled version control for the project in IntelliJ editor

Now all local SVN command work ok, changed files are displayed in blue etc.

But all operations towards the rep fails with a proxy related error again,  e.g.    Error: svn: Commit failed ......  PROPFIND request failed...

So, it seems that IntelliJ is still using the HTTP proxy settings when I do commit etc. What am I doing wrong?   The SVN browsing is working ok.

BTW, my subversion "server" config file under %APPDATA% includes my proxy's domain name.

regards,
   erik brenn

1 comment
Comment actions Permalink

Ok, solved.  My problem was that when I did checkout I did not specify the full domain of the SVN repo, I just used the servername. So my SVN proxy bypass configuration never kicked in.
I checked out again using full name of SVN server then things work fine.

I would of course have avoided this if I checked out from within IntelliJ in the first place ....

0

Please sign in to leave a comment.