disabling taglib reminders on partial pages

Hi all,

We make extensive use of JSP includes to minimize repeated page header/footer stuff, etc.

I'm going nuts with the little blue taglig definition reminders that keep getting in my way, such as /struts-tags, etc. This has gotten much worse with IDEA 8.0. (It's hard to edit at all). I cannot add these to each included page, since the page won't load. I also cannot figure out how to disable this helpful suggestion.

Two questions:

1) is there a way for IntelliJ IDEA make allowances for includes? (mark a file as not standalone)

2) if not, how do I turn off those damn reminders (hopefully selectively)

Thanks in advance

6 comments
Comment actions Permalink

JSP includes should be recognized automatically. Make sure that you include
directives are resolved to correct files and the files have correct
namespace declarations.


0
Comment actions Permalink

Would things be correct if:

1) JBoss stitched the page together properly (it looks okay)

2) the filename was green in the IDEA editor


I'm assuming that these answer your first part (pointing to right file), though not sure about the namespace one.

0
Comment actions Permalink

I cannot add these to each included page, since the page won't load.


why not? IMHO it's perfectly legal to declare <%@ taglib> multiple times when pages get included

0
Comment actions Permalink

Hm, I had the same problem - jasper validator complains about them.

Timothy: In one of the included files: Double click on Hector (the little guy in the status bar)
and check if the file context settings are correct.
You can correct them there. You can also configure the contexts for multiple files/folder in
"Project Settings" -> "Web Contexts"

Yann Cébron wrote:
>> I cannot add these to each included page, since the page won't load.


why not? IMHO it's perfectly legal to declare <%@ taglib> multiple times when pages get included

0
Comment actions Permalink

>> why not? IMHO it's perfectly legal to declare <%@ taglib> multiple times when pages get included

JBoss won't allow it, at least as far as I can tell.

Edited by: Timothy Falconer on Nov 12, 2008 12:03 AM

0
Comment actions Permalink

>> Timothy: In one of the included files: Double click on Hector (the little guy in the status bar)
>> and check if the file context settings are correct.

Wasn't able to figure out web contexts, but did find the "Import popup" checkbox, which when unchecked solves my most immediate problem, which is being able to edit.

For the life of me, I wouldn't have thought of double clicking down there for a configuration option.

Next time, please make it obvious for us to say "Please STOP being helpful ... I don't WANT help."

Edited by: Timothy Falconer on Nov 12, 2008 11:12 PM

0

Please sign in to leave a comment.