Disable Autocomplete - Braces & quote Completion

Hi,

I've been using Intellij for a while now and I edit both Java and JSPs within the IDE. I'm a keen user of Vim's keyboard mappings, and one thing that's quite irritating to me is the auto-completion of braces. When converting a large amount of XSL to JSTL, I come across it quite often: typing ${ for EL would result in Intellij inserting the closing brace, and it's actually counter-productive for me.

I've tried disabling this by unchecking 'Insert Pair' under Smart Keys in the 'Editor' settings dialogue box (CTRLALTS -> Editor), but this hasn't worked. I've also played around in the 'Code Completion' settings, but to no avail.

Searching the web & this forum didn't help much either. Any ideas?

1 comment
Comment actions Permalink

Hello atc,

The "Insert Pair '}'" option is supposed to disable this behavior. If it
hasn't worked for you, please file a JIRA issue at http://www.jetbrains.net/jira
and we'll fix this problem.

I've been using Intellij for a while now and I edit both Java and JSPs
within the IDE. I'm a keen user of Vim's keyboard mappings, and one
thing that's quite irritating to me is the auto-completion of braces.
When converting a large amount of XSL to JSTL, I come across it quite
often: typing ${ for EL would result in Intellij inserting the closing
brace, and it's actually counter-productive for me.

I've tried disabling this by unchecking 'Insert Pair' under Smart Keys
in the 'Editor' settings dialogue box (CTRLALTS -> Editor), but this
hasn't worked. I've also played around in the 'Code Completion'
settings, but to no avail.

Searching the web & this forum didn't help much either. Any ideas?

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


1

Please sign in to leave a comment.