Any ETA on when you are going to fix navigation in Diana?

Bookmarks, ctrl+b still broken and leave you far away from where you are actually trying to get to.

Build 8995

8 comments
Comment actions Permalink

Hello Samuel,

Bookmarks, ctrl+b still broken and leave you far away from where you
are actually trying to get to.


We are aware of one recent regression which caused this effect, but it's
already fixed in 8995. Does the problem still happen for you if you disable
all third-party plugins?

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I see it with third party plugins disabled on 8995. Most of the time I'm still ending up sometimes half the screen away from where I should be.

0
Comment actions Permalink

Dmitry Jemerov wrote:

Hello Samuel,

>> Bookmarks, ctrl+b still broken and leave you far away from where you
>> are actually trying to get to.


We are aware of one recent regression which caused this effect, but it's
already fixed in 8995. Does the problem still happen for you if you
disable all third-party plugins?


Happens to me even in 9111 quite frequently.

0
Comment actions Permalink

I know you said you have all 3rd party plugins disabled but you might want to double-check that you don't have the IdeaVIM plugin enabled. That plugin has caused this in the past (but appears to not cause it in 7.x). I haven't tried it in any of the Diana builds.

0
Comment actions Permalink

I have disabled the Vim plugin and have verified this after my last post and still see this happen. It does not happen as frequent as it used to but it does still happen enough to make it annoying. I'll to a clean install of Idea removing the plugins directory just to confirm.

0
Comment actions Permalink

When i did a reinstall I get a message telling me I need to buy a new license.

I'll pay for an upgrade when it's stable until then I'll stick with build 8858 and try via trial licenses when you release a few updates to see if you have made it more stable.

0
Comment actions Permalink

From my own experience with a similar problem, turning off IdeaVIM mode isn't enough, you need to completely remove the plugin. Not sure if this is actually your problem, but it was for me.

0
Comment actions Permalink

This issue may have some relevant information for you:

http://www.jetbrains.net/jira/browse/IDEA-14027

I have found that the patched IdeaVIM referenced in this issue is no longer needed.

Of course the IdeaVIM thing could be a red herring for your current issue.

0

Please sign in to leave a comment.