Can't see the caret!

My preferred Editor colour scheme is white text on black background. In
recent builds, several dialogs seem to use the colour scheme when prompting
for code snippets (evaluate expression, refactor->rename etc), but they
don't correctly show a white caret on the black background. Anyone else
experiencing this? Nathan?


6 comments

Hey Colin, well I too use a black background, but don't see this
problem. I've always had to set my caret colour to black foreground
(no background) to get it to display on a black background - must be due
to some XOR'ing going on when the caret is painted. Is that your setting?

N.

Colin Smith wrote:

My preferred Editor colour scheme is white text on black background. In
recent builds, several dialogs seem to use the colour scheme when prompting
for code snippets (evaluate expression, refactor->rename etc), but they
don't correctly show a white caret on the black background. Anyone else
experiencing this? Nathan?


0

Yeah, that kind of fixes it. I was using a very dark grey background for the
caret row; with that turned on, the caret flashes black on dark grey.
Without it, it is white.

Now though, when doing a find usages etc, the current line of code isn't
highlighted in the editor. How do u solve that one?

Colin

Hey Colin, well I too use a black background, but don't see this
problem. I've always had to set my caret colour to black foreground
(no background) to get it to display on a black background - must be due
to some XOR'ing going on when the caret is painted. Is that your setting?

>

N.

>

Colin Smith wrote:

>

My preferred Editor colour scheme is white text on black background. In
recent builds, several dialogs seem to use the colour scheme when

prompting

for code snippets (evaluate expression, refactor->rename etc), but they
don't correctly show a white caret on the black background. Anyone else
experiencing this? Nathan?

>
>

>


0

Caret row is explicitly set to null in one line editors. So it seems you
have to have a caret color that both looks good on caret row background and
general background.

--

Best regards,
Maxim Shafirov
JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"


"Colin Smith" <csmith@axiomsystems.com> wrote in message
news:bobf0a$71c$1@is.intellij.net...

Yeah, that kind of fixes it. I was using a very dark grey background for

the

caret row; with that turned on, the caret flashes black on dark grey.
Without it, it is white.

>

Now though, when doing a find usages etc, the current line of code isn't
highlighted in the editor. How do u solve that one?

>

Colin

>
>

Hey Colin, well I too use a black background, but don't see this
problem. I've always had to set my caret colour to black foreground
(no background) to get it to display on a black background - must be due
to some XOR'ing going on when the caret is painted. Is that your

setting?

>

N.

>

Colin Smith wrote:

>

My preferred Editor colour scheme is white text on black background.

In

recent builds, several dialogs seem to use the colour scheme when

prompting

for code snippets (evaluate expression, refactor->rename etc), but

they

don't correctly show a white caret on the black background. Anyone

else

experiencing this? Nathan?

>
>

>

>
>


0

Yeah, I don't have a caret row colour set, so I'm fine everywhere.

N.

Maxim Shafirov (JetBrains) wrote:

Caret row is explicitly set to null in one line editors. So it seems you
have to have a caret color that both looks good on caret row background and
general background.


0

By the way Colin, if you choose to mirror my configuration, you might be
interested in this bug :
http://www.intellij.net/tracker/idea/viewSCR?publicId=20559

N.

Nathan Brown wrote:

Yeah, I don't have a caret row colour set, so I'm fine everywhere.

N.

Maxim Shafirov (JetBrains) wrote:

>> Caret row is explicitly set to null in one line editors. So it seems you
>> have to have a caret color that both looks good on caret row
>> background and
>> general background.
>>


0

I want a white caret on a black background, so I have created a Tracker
request for this....

http://www.intellij.net/tracker/idea/viewSCR?publicId=20895

"Maxim Shafirov (JetBrains)" <max@intellij.net> wrote in message
news:bobigc$ovb$1@is.intellij.net...

Caret row is explicitly set to null in one line editors. So it seems you
have to have a caret color that both looks good on caret row background

and

general background.

>

--

>

Best regards,
Maxim Shafirov
JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"

>
>

"Colin Smith" <csmith@axiomsystems.com> wrote in message
news:bobf0a$71c$1@is.intellij.net...

Yeah, that kind of fixes it. I was using a very dark grey background for

the

caret row; with that turned on, the caret flashes black on dark grey.
Without it, it is white.

>

Now though, when doing a find usages etc, the current line of code isn't
highlighted in the editor. How do u solve that one?

>

Colin

>
>

Hey Colin, well I too use a black background, but don't see this
problem. I've always had to set my caret colour to black foreground
(no background) to get it to display on a black background - must be

due

to some XOR'ing going on when the caret is painted. Is that your

setting?

>

N.

>

Colin Smith wrote:

>

My preferred Editor colour scheme is white text on black background.

In

recent builds, several dialogs seem to use the colour scheme when

prompting

for code snippets (evaluate expression, refactor->rename etc), but

they

don't correctly show a white caret on the black background. Anyone

else

experiencing this? Nathan?

>
>

>

>
>

>
>


0

Please sign in to leave a comment.