Can no longer debug jsp's HELP!

hello
for some reason i can not longer debug jsps
I have tried creating a new project
The breakpoints in the jsp are a redball(not a redball with an X). but when i run the app, the jsp displays without stopping at the breakpoint.
I am running intellij build 698
tomcat Apache Tomcat/4.0.4

any suggestions?

Thanks

7 comments
Comment actions Permalink

The breakpoints in the jsp are a redball(not a redball with an X). but when i run the app, the jsp displays without stopping at

the breakpoint.

If breakpoint's icon dos not change, (there's no checkmark on it), it means that Tomcat loads classes from a different place. Please
check that it loads exactly those clases that are compiled from your JSPs

--

Best regards,
Eugene Zhuravlev
JetBrains, Inc, http://www.intellij.com
"Develop with pleasure!"


0
Comment actions Permalink

How do you "check that it loads exactly those classes that are compiled from your JSPs"

the app runs, and the jsps work.

Please help, really need to get this working
Thanks for any help

0
Comment actions Permalink

i have the same trouble. I'm using resin. During the debuging, i open the .java file that my jsp was translated and set a breakpoint, then it's worked. why? can i debug my jsp in source-level? thanks

0
Comment actions Permalink

compass wrote:

i have the same trouble. I'm using resin. During the debuging, i open the .java file that my jsp was translated and set a breakpoint, then it's worked. why? can i debug my jsp in source-level? thanks

Not sure what problem you have but I can debug. It does throw an
exception from time to time, but it work.

You might also be having problems with the resin plugin itself, i've
seen issues with it lately, and am not sure how to contact the author
since his email listed on wiki bounces back.

I might just take on debugging and fixing it for later builds myself
since the original author was kind enough to distribute the source.

Try the Tomcat plugin.
R

0
Comment actions Permalink

Using Tomcat 5 I have been able to debug various servlets, struts apps and such.

I can not seem to get it to break on JSP however.

I am running the Tomcat plugin. Interesting I am seeing my jsps in two places. One in my src location and one in the 'production' location pointed to by the web application setup. The ones in src claim to show errors saying they can't locate the tld files, however the ones in the prodution location show 'green'. I've tried setting break points in both but haven't had any luck so far. They compile and run properly but never break. In contrast other servlet code breaks correcly.

-Noah

0
Comment actions Permalink

This is under bld 957.

0
Comment actions Permalink

Fixed in #963.
Now we support Tomcat 5

0

Please sign in to leave a comment.