IDEA 7.0.4 (7941) - big pauses (several mins) after doing search & replace

Hi,

This might be just my large-ish project (or XP) causing problems, but when I do a search and replace within one file, IDEA locks up for 5 minutes or so before I can continue.

Anyone else seeing this kind of problem, or is it just me :(

I have updated my vmoption's to mx512m - I was getting the slowdown before, and I thought this might help... but it hasn't.

Thanks,
Chris

7 comments
Comment actions Permalink

Hello Chris,

This might be just my large-ish project (or XP) causing problems, but
when I do a search and replace within one file, IDEA locks up for 5
minutes or so before I can continue.

Anyone else seeing this kind of problem, or is it just me :(

I have updated my vmoption's to mx512m - I was getting the slowdown
before, and I thought this might help... but it ehasn't.


Pleasie take a CPU snapshot as described in http://support.jetbrains.com/kb/entry.jspa?externalID=192&categoryID=5

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

I am having the same problem - see : http://intellij.net/forums/thread.jspa?threadID=277091&tstart=0

I am going to have a read through the link posted by Dmitry Jemerov

0
Comment actions Permalink

Hi,

I tried it with a similarly sized file in a new project and things work fine - so I guess its related to the other fluff in my project.

I have got a cpu snapshot, but struggling with a way to get the 2mb file ftp'd - the work proxy does not like that kind of thing (ftp), so I will send it from home later.

Regards,
Chris

0
Comment actions Permalink

Hi,

cpu snapshot uploaded via ftp - 7941_kimptonc_05.09.2008_10.26.27.zip

Regards,
Chris

0
Comment actions Permalink

Hello Chris,

cpu snapshot uploaded via ftp - 7941_kimptonc_05.09.2008_10.26.27.zip


Unfortunately the snapshot got corrupted during the FTP upload. Could you
please create a JIRA issue at http://www.jetbrains.net/jira/ and attach the
snapshot to it?

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hi,

I have the SQL script editor plugin installed and disabling it gets rid of the time delay.

I guess thats the source of the problem.

Regards,
Chris

0

Please sign in to leave a comment.