the red bubble

hello all,

a couple questions

1. sometimes the red bubble appears when we do something wrong like for example i have implemented a interface and i have not implemented all its methods, it will give a tool tip saying i have to implement the methods and sometimes the red bubble appears on the left using which a default implementation of the un-implemented methods can be added. How can i get that bubble with any particular shortcut key or any menu. Right now when i see that tool tip i just wait and sometimes the red bubble appears but sometimes it doesn't

2. if i am typing the name of a class which is not present in the currently imported packages i don't get its name with auto complete i.e. by pressing space bar (like in eclipse if i press space it would present me the list of classes starting with that name or alphabet) but if i type the complete class name it will then present me with that option , any idea how can i enable the auto complete for a class name like in eclipse ?

3. Finally, my compilations doesn't seem to work for some reason. If i compile it just says compilation successfull

Singh

Edited by: Singh on Aug 20, 2008 9:51 PM

8 comments
Comment actions Permalink

Hello Singh,

1. sometimes the red bubble appears when we do something wrong like
for example i have implemented a interface and i have not implemented
all its methods, it will give a tool tip saying i have to implement
the methods and sometimes the red bubble appears on the left using
which a default implementation of the un-implemented methods can be
added. How can i get that bubble with any particular shortcut key or
any menu. Right now when i see that tool tip i just wait and sometimes
the red bubble appears but sometimes it doesn't


Press Alt+Enter

2. if i am typing the name of a class which is not present in the
currently imported packages i don't get its name with auto complete
i.e. by pressing space bar (like in eclipse if i press space it would
present me the list of classes starting with that name or alphabet)
but if i type the complete class name it will then present me with
that option , any idea how can i enable the autocomplete for a class
name like in eclipse ?


Press Ctrl-Alt-Space to show a completion list which includes classes you
haven't imported.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hello Singh,

In regards to question #2, I recommend you take a look at the "Auto-Completing Code" section in the IDEA help (IntelliJ IDEA /  Procedures /  Advanced Editing Procedures /  Auto-Completing Code).

IDEA's auto completing works a little different then Eclipse with its three variations:
- Basic code completion via Ctrl+Space
- SmartType Code Completion via CtrlShiftSpacebar
- Class names completion on CtrlAltSpace

When I came over to IDEA from Forte for Java six-years ago, it took me a little bit to get use the having the three different code completes. (Reading the help pages on them to understand the differences helped.) I quickly found as I used them that it does make things a lot simpler; now I don't know how I ever lived without them. Some of my co-workers that have converted over from Eclipse had almost identical experiences. A brief "get use to it" factor, and then a strong appreciation for it. Also, some of the things eclipse made available on ctrlspace are available on other keys in IDEA. For example the code templates via ctrlJ.

As for question #3, what do you mean the compilation does not work? Are you not getting classes in the output directory? That directory is set under the project settings' "general" settings. It defaults to <project-root>/out. Ultimately the classes will be in <project-root>/out/production/<module-name> and <project-root>/out/test/<module-name> for test classes. It can also be overridden on a per module basis on the "Paths" tab for a module.

The other thing to keep in mind is that a compile can seem very quick since it (by default) only complies files that have been modified. A "rebuild project" will rebuild everything. And can be set in Setting | Project Settings | Compiler to clear the output directory on a rebuild. More info is available in the help under IntelliJ IDEA /  Procedures /  Compiling Applications.

0
Comment actions Permalink

Hello Singh,

In regards to question #2, I recommend you take a look at the "Auto-Completing Code" section in the IDEA help (IntelliJ IDEA /  Procedures /  Advanced Editing Procedures /  Auto-Completing Code).

IDEA's auto completing works a little different then Eclipse with its three variations:
- Basic code completion via Ctrl+Space
- SmartType Code Completion via CtrlShiftSpacebar
- Class names completion on CtrlAltSpace


Interesting. I will definitely look at it


When I came over to IDEA from Forte for Java six-years ago, it took me a little bit to get use the having the three different code completes. (Reading the help pages on them to understand the differences helped.) I quickly found as I used them that it does make things a lot simpler; now I don't know how I ever lived without them. Some of my co-workers that have converted over from Eclipse had almost identical experiences. A brief "get use to it" factor, and then a strong appreciation for it. Also, some of the things eclipse made available on ctrlspace are available on other keys in IDEA. For example the code templates via ctrlJ.

As for question #3, what do you mean the compilation does not work? Are you not getting classes in the output directory? That directory is set under the project settings' "general" settings. It defaults to <project-root>/out. Ultimately the classes will be in <project-root>/out/production/<module-name> and <project-root>/out/test/<module-name> for test classes. It can also be overridden on a per module basis on the "Paths" tab for a module.


Yes i had my output directory set and i believe I was getting my class files in that, although i didn't verify them.

What i did was I removed a semicolon to make a compilation error and it would give me that error. I also tried doing a rebuild but it didn't help. Later i saw that there were class files (coz of my ant scirpt) in the source directory itself (under each package directory where the java files resided). I believe that was the reason it would just say compilation completed successfully but never detected those compilation errors. After removing the class files from the source locations it worked fine


The other thing to keep in mind is that a compile can seem very quick since it (by default) only complies files that have been modified. A "rebuild project" will rebuild everything. And can be set in Setting | Project Settings | Compiler to clear the output directory on a rebuild. More info is available in the help under IntelliJ IDEA /  Procedures /  Compiling Applications.


Yes i played with this entry but didn't help


Thanks & Regards
Singh

0
Comment actions Permalink

in eclipse ctrl + o would list down all the methods of that particular class, Is there any equivalent in intellij ? i really miss this feature

Singh

0
Comment actions Permalink

try ctrl+F12 , this may be what you're looking for ?

0
Comment actions Permalink

yup, this is what i was looking for

thanks :)

0
Comment actions Permalink

I can't help making this remark:
Really, just at least once have a close look at each item in IDEA's main menu.
You might find some other treasures you don't know about yet.

Singh wrote:

yup, this is what i was looking for

thanks :)

0
Comment actions Permalink

I can't help making this remark:
Really, just at least once have a close look at each item in IDEA's main menu.
You might find some other treasures you don't know about yet.


Sure thing. Since i am in a transition mode, i just wanted to get things going. I have figured out most part of things except for a few.
What i have learnt is this : If you do a "transition" to IDEA, its a little different. IDEA should be taken up (as a IDE) with a clean slate, and then you will learn well, enjoy and use its powerful features


Singh wrote:

yup, this is what i was looking for

thanks :)

>

0

Please sign in to leave a comment.