Subversion 1.5 support?

How can I tell what version of Subversion the subversion plugin is compatible with? Now that subversion 1.5 is officially released, can IntelliJ talk to a subversion 1.5 server with a 1.5 sandbox?

11 comments
Comment actions Permalink

Hello Shawn,

How can I tell what version of Subversion the subversion plugin is
compatible with? Now that subversion 1.5 is officially released, can
IntelliJ talk to a subversion 1.5 server with a 1.5 sandbox?


Not yet. (The server should be OK, but the working copy format is not compatible.)
Subversion 1.5 support will be included in 7.0.4 final and will likely appear
in the next EAP build for 7.0.4.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Dmitry, please also fix serious bugs in 7.0.4 final (see
http://www.intellij.net/forums/thread.jspa?threadID=275941&tstart=15).

Tom

0
Comment actions Permalink

Hi,

As another subversion 1.5 upgrader, any news on a date for 7.0.4 official release ?

Thanks,
Chris

0
Comment actions Permalink

Hello Chris,

As another subversion 1.5 upgrader, any news on a date for 7.0.4
official release ?


As soon as we are certain that there are no major regressions. Subversion
1.5 support is a lot of new code, and it's taking time to stabilize.

You're very much welcome to use 7.0.4 RC builds from http://www.jetbrains.net/confluence/display/IDEADEV/Selena+EAP

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

So as someone who has a upgrade scheduled for my companies Subversion repository from 1.3.2 to 1.5.1 I am interested in this thread. So if I touch my working copy with a Subversion 1.5 client IntelliJ will no longer be able to offer Subversion integration for that working copy? (until 7.0.4 anyway)

0
Comment actions Permalink

Hello Michael,

So as someone who has a upgrade scheduled for my companies Subversion
repository from 1.3.2 to 1.5.1 I am interested in this thread. So if I
touch my working copy with a Subversion 1.5 client IntelliJ will no
longer be able to offer Subversion integration for that working copy?
(until 7.0.4 anyway)


That's correct. Note that IntelliJ IDEA before 7.0.4 is also not fully compatible
with version 1.5 servers.
The recommended course of action at the moment is upgrading to the 7.0.4
RC build available from http://www.jetbrains.net/confluence/display/IDEADEV/Selena+EAP

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Thanks for the info. Glad I read this thread or I wouldn't have known I couldn't use 7.0.3 with a 1.5 repository. I will just use the 7.0.4 eap.

Out of curiosity is the release date for the official 7.0.4 release measured in weeks? Or months?

Edited by: Michael Parmeley on Aug 10, 2008 3:26 AM

0
Comment actions Permalink

Hello Michael,

Thanks for the info. Glad I read this thread or I wouldn't have known
I couldn't use 7.0.3 with a 1.5 repository. I will just use the 7.0.4
eap.

Out of curiosity is the release date for the official 7.0.4 release
measured in weeks? Or months?


Days, I would say.

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Hi,

Tried 7.0.4 RC (build 7938), but it fails to startup - some error, see below. Then all the code is red, as its seems to have failed to find the jdk. The same one that 7.0.3 finds with no trouble at all. I would have submitted that from within IDEA, but the submission form keeps saying my ITN login is invalid - even when I dont enter the optional details...

Regards,
Chris

No message
java.lang.NullPointerException
at com.intellij.psi.impl.cache.impl.repositoryCache.RepositoryCache.e(RepositoryCache.java:278)
at com.intellij.psi.impl.cache.impl.repositoryCache.RepositoryCache.a(RepositoryCache.java:319)
at com.intellij.psi.impl.cache.impl.repositoryCache.RepositoryCache.a(RepositoryCache.java:40)
at com.intellij.psi.impl.cache.impl.repositoryCache.RepositoryCache.]]>(RepositoryCache.java:272)
at com.intellij.psi.impl.cache.impl.GlobalRepositoryManager.getCache(GlobalRepositoryManager.java:15)
at com.intellij.psi.impl.cache.impl.RepositoryManagerImpl.a(RepositoryManagerImpl.java:36)
at com.intellij.psi.impl.cache.impl.RepositoryManagerImpl.queryNeededFiles(RepositoryManagerImpl.java:313)
at com.intellij.ide.startup.FileSystemSynchronizer.collectFilesToUpdate(FileSystemSynchronizer.java:108)
at com.intellij.ide.startup.FileSystemSynchronizer.execute(FileSystemSynchronizer.java:69)
at com.intellij.ide.startup.impl.StartupManagerImpl$2.run(StartupManagerImpl.java:5)
at com.intellij.openapi.application.impl.ApplicationImpl.runReadAction(ApplicationImpl.java:104)
at com.intellij.ide.startup.impl.StartupManagerImpl.runStartupActivities(StartupManagerImpl.java:34)
at com.intellij.openapi.project.impl.ProjectManagerImpl$3.run(ProjectManagerImpl.java:3)
at com.intellij.openapi.progress.impl.ProgressManagerImpl$2.run(ProgressManagerImpl.java:3)
at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(ProgressManagerImpl.java:33)
at com.intellij.openapi.progress.impl.ProgressManagerImpl.runProcess(ProgressManagerImpl.java:81)
at com.intellij.openapi.application.impl.ApplicationImpl$7$1.run(ApplicationImpl.java:13)
at com.intellij.openapi.application.impl.ApplicationImpl$5.run(ApplicationImpl.java:3)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
at java.lang.Thread.run(Thread.java:619)
at com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(ApplicationImpl.java:2)

0
Comment actions Permalink

Hello Chris,

Please clear the caches directory.

Tried 7.0.4 RC (build 7938), but it fails to startup - some error, see
below. Then all the code is red, as its seems to have failed to find
the jdk. The same one that 7.0.3 finds with no trouble at all. I
would have submitted that from within IDEA, but the submission form
keeps saying my ITN login is invalid - even when I dont enter the
optional details...

Regards,
Chris
No message
java.lang.NullPointerException
at
com.intellij.psi.impl.cache.impl.repositoryCache.RepositoryCache.e(Rep
ositoryCache.java:278)
at
com.intellij.psi.impl.cache.impl.repositoryCache.RepositoryCache.a(Rep
ositoryCache.java:319)
at
com.intellij.psi.impl.cache.impl.repositoryCache.RepositoryCache.a(Rep
ositoryCache.java:40)
at
com.intellij.psi.impl.cache.impl.repositoryCache.RepositoryCache.<init
>(RepositoryCache.java:272)
at
com.intellij.psi.impl.cache.impl.GlobalRepositoryManager.getCache(Glob
alRepositoryManager.java:15)
at
com.intellij.psi.impl.cache.impl.RepositoryManagerImpl.a(RepositoryMan
agerImpl.java:36)
at
com.intellij.psi.impl.cache.impl.RepositoryManagerImpl.queryNeededFile
s(RepositoryManagerImpl.java:313)
at
com.intellij.ide.startup.FileSystemSynchronizer.collectFilesToUpdate(F
ileSystemSynchronizer.java:108)
at
com.intellij.ide.startup.FileSystemSynchronizer.execute(FileSystemSync
hronizer.java:69)
at
com.intellij.ide.startup.impl.StartupManagerImpl$2.run(StartupManagerI
mpl.java:5)
at
com.intellij.openapi.application.impl.ApplicationImpl.runReadAction(Ap
plicationImpl.java:104)
at
com.intellij.ide.startup.impl.StartupManagerImpl.runStartupActivities(
StartupManagerImpl.java:34)
at
com.intellij.openapi.project.impl.ProjectManagerImpl$3.run(ProjectMana
gerImpl.java:3)
at
com.intellij.openapi.progress.impl.ProgressManagerImpl$2.run(ProgressM
anagerImpl.java:3)
at
com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessU
nderProgress(ProgressManagerImpl.java:33)
at
com.intellij.openapi.progress.impl.ProgressManagerImpl.runProcess(Prog
ressManagerImpl.java:81)
at
com.intellij.openapi.application.impl.ApplicationImpl$7$1.run(Applicat
ionImpl.java:13)
at
com.intellij.openapi.application.impl.ApplicationImpl$5.run(Applicatio
nImpl.java:3)
at
java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441
)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
at java.util.concurrent.FutureTask.run(FutureTask.java:138)
at
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecu
tor.java:885)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.
java:907)
at java.lang.Thread.run(Thread.java:619)
at
com.intellij.openapi.application.impl.ApplicationImpl$1$1.run(Applicat
ionImpl.java:2)

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Yay!

That did the trick, svn support back in IDEA - was really missing it :(

Thanks,
Chris

0

Please sign in to leave a comment.