Local History not working in Intellij7.0.3

I recently upgraded to 7.0.3 from 7.0.2.
I noticed today that the 'Local History' is not working
I right click a file in the Project windows and select 'LocalHistory/ShowHistory...'. There is absolutely no response from the IDE.

I looked at my IDE configurations for 'Local History' it is set to all defaults - 3 days of History and default labeling on all options available.

Am I missing something?

This feaure worked impeccably well in Intellij 5.x. Since the upgrade to IntelliJ 7.x I notices some unusual behaviour and now it is completely gone.
Have I hit a celing /some sort of 'Max' iin the amount of available disk space??
Any ideas on how to resolve this will be appreciated.

Please let me know if I can provide more information.

13 comments
Comment actions Permalink

Does your log file contain any exceptions concerning local history?

0
Comment actions Permalink

Anton
The idea.log file is attached.
I picked it up from the $User\.IntelliJIdea70\system\log directory.
Hope this is the one you are looking for? There a quite a few error in this file.

I should also mention that before I noticed the 'LocalHistory not working', I had had my .iws file corrupted a few days ago.
I deleted the corrupt file and let IDEA create a new one. I am not sure if these issues are related but thought it was worth mentioning.

Some of my other colleagues have had the issue of .iws/.ipr file getting corrupted too.. It seems like it happens on undocking laptops from docking stations.

Thanks
Ranjana



Attachment(s):
idea.log
0
Comment actions Permalink

Could you recall what C:/ig88 is?
It seems that something went wrong with the file system and affected local history.

0
Comment actions Permalink

Could you recall what C:/ig88 is?
It seems that something went wrong with the file system and affected local history.

0
Comment actions Permalink

C:\ig88 is the directory where the project file and source code is located.

0
Comment actions Permalink

Do you remember what the ipr/iws corruption was like and what was the reason?

0
Comment actions Permalink

Anton
As best as I can remember it said something about a 'configuration' element not being present.

I still have the .iws file in my 'Recyle Bin'. It has a size of 114kb but when i opened it up with a text editor it had only nulls in it.
If you wish I can attach it.

I am guessing I will have to recreate this project all over again. Please let me know if there is a way to salvage the current project and still get my Local History to work.

Thanks
Ranjana

0
Comment actions Permalink

I created a brand new project but still retained the original location of c:/ig88.
The local history is still not working.
I cannot change the location of the project or the name.
Is there any other way to resolve this issue.

thanks
Ranjana

0
Comment actions Permalink

I have run into a problem in the past where my local history disappeared, and the problem was that the local history is dependent not only on the filename but also the project name/path.

What I had done in the past was before upgrading IDEA, I would rename my "projects" directory to "projects703" or something, and that would have the effect of invalidating my local history, even though all the source files were still in the same location.

You might have done something similar?
Your last attempt at recreating a new project will definitely not work. The new project will have a completely new local history, even if the contained files are the same.

I think a Jetbrains developer said they might fix this in the next release 8.0.x, but don't hold your breath...

0
Comment actions Permalink

Thanks Alex
What I noticed is even after I created the 'new' project (with the same project name and path as the old one), I still could not see any local History at all.

What did work is - deleting the cache from ..\.IntelliJIdea70\system\caches. There seemed to be something in there that was causing idea to generate an exception and not load the local history.

I

0
Comment actions Permalink

I now have the same problem but I think it's related to a Java update a couple of days ago.
My Java is now
java version "1.6.0_07"
Java(TM) SE Runtime Environment (build 1.6.0_07-b06)
Java HotSpot(TM) Client VM (build 10.0-b23, mixed mode, sharing)


From idea.log (also attached)
2008-08-06 08:41:01,813 ERROR - com.intellij.ide.IdeEventQueue - IntelliJ IDEA 7.0.3 Build #7757
2008-08-06 08:41:01,813 ERROR - com.intellij.ide.IdeEventQueue - JDK: 1.6.0_04
2008-08-06 08:41:01,813 ERROR - com.intellij.ide.IdeEventQueue - VM: Java HotSpot(TM) Client VM
2008-08-06 08:41:01,813 ERROR - com.intellij.ide.IdeEventQueue - Vendor: Sun Microsystems Inc.
2008-08-06 08:41:01,813 ERROR - com.intellij.ide.IdeEventQueue - OS: Windows XP
2008-08-06 08:41:01,813 ERROR - com.intellij.ide.IdeEventQueue - Last Action: LocalHistory.ShowHistory
2008-08-06 08:47:06,920 ERROR - com.intellij.ide.IdeEventQueue - Error during dispatching of java.awt.event.MouseEvent[MOUSE_RELEASED,(51,9),absolute(711,55),button=1,modifiers=Button1,clickCount=1] on ###overrideRedirect###
java.lang.RuntimeException: entry '-1.2611.2612.2613.2614.2615.2616.2617.2973' not found
at com.intellij.history.core.tree.Entry.getEntry(Entry.java:34)
at com.intellij.history.core.changes.ContentChange.revertOn(ContentChange.java:16)
at com.intellij.history.core.changes.ChangeList$ChangeCollectingVisitor.b(ChangeList.java:25)
at com.intellij.history.core.changes.ChangeList$ChangeCollectingVisitor.a(ChangeList.java:27)
...

at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)
2008-08-06 08:47:06,920 ERROR - com.intellij.ide.IdeEventQueue - IntelliJ IDEA 7.0.3 Build #7757
2008-08-06 08:47:06,920 ERROR - com.intellij.ide.IdeEventQueue - JDK: 1.6.0_04
2008-08-06 08:47:06,920 ERROR - com.intellij.ide.IdeEventQueue - VM: Java HotSpot(TM) Client VM
2008-08-06 08:47:06,920 ERROR - com.intellij.ide.IdeEventQueue - Vendor: Sun Microsystems Inc.
2008-08-06 08:47:06,920 ERROR - com.intellij.ide.IdeEventQueue - OS: Windows XP
2008-08-06 08:47:06,920 ERROR - com.intellij.ide.IdeEventQueue - Last Action: LocalHistory.ShowHistory

I rely heavily on local history an this problem is pretty painful - any help would be appreciated.

Tom



Attachment(s):
idea.log
0
Comment actions Permalink

I now have the same problem but I think it's related to a Java update a couple of days ago.
My Java is now
java version "1.6.0_07"
Java(TM) SE Runtime Environment (build 1.6.0_07-b06)
Java HotSpot(TM) Client VM (build 10.0-b23, mixed mode, sharing)


How certain are you of that? From the traces you gave, it looks like IDEA is still running under 1.6.0_04.


Randall Schulz

0
Comment actions Permalink

I still had the jre in the IntelliJ install folder. Removed it and made sure that IntelliJ knows where the new version is by creating
EXE4J_JAVA_HOME
I still have the same problem but the log file only references the jdk1.6.0_07

Still sadly have no local history. The new log file is attached.



Attachment(s):
idea.log
0

Please sign in to leave a comment.