Ctrl-Space doesn't seem to work in IDEA anymore - How do you turn it on?

Hi,

I'm using the latest IDEA off the download page. I'm encountering a strange problem - every time I press CTRL-SPACE to have the IDE auto-type for me, it doesn't work. It does nothing at all. However, if I go up Code->Complete Code->Basic... it works fine. Any way to re-enable CTRL-SPACE shortcut so that it does what it is supposed to? This is really annoying since I use this feature religiously to speed things up. Thanks.

Ken

9 comments
Comment actions Permalink

If you look at the menu item text: Does it show "Ctrl-Space" as the action's shortcut?
If not you can configure (or reset) that in the keymap: File -> Settings -> IDE Settings -> Keymap

If that looks ok, chances are there is a third party tool that eats the keystroke.
Did you recently install any software?
On some Linux OSs/Desktops there are also many keystrokes that are intercepted before they reach IDEA.

If all that does not help, err., get a new keyboard? ;)

Ken wrote:

Hi,

I'm using the latest IDEA off the download page. I'm encountering a strange problem - every time I press CTRL-SPACE to have the IDE auto-type for me, it doesn't work. It does nothing at all. However, if I go up Code->Complete Code->Basic... it works fine. Any way to re-enable CTRL-SPACE shortcut so that it does what it is supposed to? This is really annoying since I use this feature religiously to speed things up. Thanks.

Ken

1
Comment actions Permalink

Hi Stephen,

It does say "CTRL-SPACE" next to the menu item. I also went into the keymap (just to be sure), and it also says CTRL-SPACE is the shortcut.

So I started closing some programs just to see. Apparantly the logitech webcam program in the tray is the culprit. Sigh...

I went into its settings and there are no short-cut preferences at all. So basically, it just decided to hi-jack that shortcut for no reason whatsoever.

Thanks for the help. At least I solved the problem. Too bad I coded for a few days without CTRL-SPACE. Man, that was actually painful

0
Comment actions Permalink

I have a similar problem with gnome. Other than reassigning keybindings one by one, is there a way to have idea
win the keybinding race always? My guess is no, since it doesn't see the keys until after gnome/kde/xfce.

0
Comment actions Permalink

Just a small note, if someone finds this searching for other reasons why code completion might stop working:

I sometimes find that, after having worked with an IDEA instance for a few hours, code completion and some other editor features break and nothing will help but shutdown all IDEA frames and reopen the project(s).

- Denis

0
Comment actions Permalink

Which features don't work? And which do work? Could you give more
details? What do you do before everything stops working? Which version
are you using?

0
Comment actions Permalink

I'll post a message as soon as I encounter this again!

0
Comment actions Permalink

Our team has just been forced to work over a Citrix/remote desktop connection. I was forced to re-map about 10 shortcuts because these have special meanings now. Very annoying!

Regards,
Jens

0
Comment actions Permalink

If you plug an other keyboard, possibly runs automatically ibus.

Just run "ibus-setup" and change the kb shortcut or remove ibus completely if you don't need it.

Javier.

0
Comment actions Permalink

For all using Mac OS X, Ctrl-Space seems to be the default binding for "Select the previous input source".

You can unbind it in the keyboard shortcuts settings: https://stackoverflow.com/a/42668983/3160483

0

Please sign in to leave a comment.