IDEA on AIX?

I'd like to get IDEA up and running on an AIX box, as I don't yet have and IDE that works with AIX.
I've followed the usual unix installation steps, but the only problem is that sun doesn't provide a JRE for AIX, only IBM does as far as I know.
I tried using IBM jvm 1.4.0, but IDEA seems to insist on the specific point version 1.4.1_01, which of course is not available on the AIX platform.
Is there any way to relax this restriction? I don't mind running an unsupported (and perhaps somewhat buggy) IDE, since the only thing I currently have is VI/ANT.

Thanks
James

7 comments
Comment actions Permalink

have you tried 3.0.5? It should work. If you do a search there is a way of disabling the jvm check. Do a search for 1.4.2. When 1.4.2 first came out we all asked how to get rid of the check and one of the jetbrain folks posted a switch to use.

0
Comment actions Permalink

I can't seem to find any threads concerning disabling the JVM version check. Do you happen to know the switch off hand?

James

0
Comment actions Permalink

-Didea.no.check.jdk=true

you may have to install a jre under the $ directory replacing the existing one. The latest eap version may not support this but others should

0
Comment actions Permalink

this doesn't seem to work on my version of idea.
i'm using 3.0.5. the name of the download binary is: idea-3.0.5v2.tar.

Do you happen to know which versions of idea this switch is valid for? Should I be using one of the aurora builds?

Thanks,

James

0
Comment actions Permalink

Are you adding it to the startup and .lax file as Marcus notes below?

Marcus Brito wrote:

Edit your idea.lax file (or idea.bat, or idea.sh), change the JRE home to
whatever you like, and add -Didea.no.check.jdk=true to the JVM options. Make
sure the 'tools.jar' file is in the classpath.

But if you do so, don't bother to ever post a bug report that's slightly
related to the virtual machine. JetBrains folks bundle the JRE for a good
reason, and is to avoid dealing with different versions of the JVM.

Believe them: the JVM is buggy, and there's lots of workaround code in
IDEA. By constraining users to a single JRE, JetBrains folks are making sure
their workarounds really work.

0
Comment actions Permalink

i found what the problem was.
the switch is actually:

"-Didea.no.jdk.check=true" not
"-Didea.no.check.jdk=true"

Thank you very much for your help, and like Marcus said, I won't bother asking intellij to support my configuration.

James

0
Comment actions Permalink

Kojo is right, the variable is idea.no.jdk.check. Sorry for the mispelling ^^

0

Please sign in to leave a comment.