Unexpected application exit under IDEA

I'm getting a very strange and unexpected application exit when running/debugging in IDEA on Windows XP SP2.

The application is a standard Java client GUI that logs in to a server to access data. Until last week, it has been running fine in various versions in and out of IDEA for a couple of years.

The problem that has started is that when running under IDEA and the login dialog is displayed waiting for the password to be entered, any key press causes an immediate application exit, with the message:

Process finished with exit code -1073741819

There are no console error messages, nothing in the application log, nothing in the IDEA log, and nothing in the Windows event logs. If I set IDEA to break on any exception, no exception is trapped.

This happens regardless of the JVM version I use to run the application, and regardless of which version of IDEA I run it on. If I run exactly the same class files from a batch on the Windows command line, the login dialog works as expected - allowing you to type a password and log in.

I've tries changing the memory options, and debugging with the verbose setting, but I just can't find what's happening.

Has anyone got any ideas?

Please sign in to leave a comment.