Connecting to sourcesafe repository

I am trying to set-up my intellij IDEA (7.0.3) to point to a remote Sourcesafe repository.
I can use a SourceSafe client to connect to the repository fine by specifying the UNC location of the srcsafe.ini file (
server\path_to_repository\srcsafe.ini) and specifying the username/password, but IDEA fails to connect to the repository with the same parameters. I don't see the list of projects in the dropdown and I when I open my project I get:
Please specify correct VSS project(s) in the project's content roots.
I couldn't find any useful information in the idea.log file attached.
How can I track what's going on? Is there any option that I can change that would generate more information in the log?

Thanks.

Aymeric



Attachment(s):
idea.log
4 comments
Comment actions Permalink

Hello Aymeric,

You need to go to Settings | Version Control | Directory Version Control
Settings, select the necessary VCS root, press the "Edit..." button and specify
the connection settings in the dialog that will appear.

I am trying to set-up my intellij IDEA (7.0.3) to point to a remote
Sourcesafe repository.

I can use a SourceSafe client to connect to the repository fine by
specifying the UNC location of the srcsafe.ini file
(
server\path_to_repository\srcsafe.ini) and specifying the
username/password, but IDEA fails to connect to the repository with
the same parameters. I don't see the list of projects in the dropdown
and I when I open my project I get:

+Please specify correct VSS project(s) in the project's content
roots.+

I couldn't find any useful information in the idea.log file attached.

How can I track what's going on? Is there any option that I can change
that would generate more information in the log?

Thanks.

Aymeric

--
Dmitry Jemerov
Development Lead
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

Dmitry,

Thanks for looking into the issue. I already went through the steps you described.
When I click OK in the 'Configure VCS ...' window, nothing happen I don't see any project listed under 'VSS Projects:' in the 'Edit VCS Directory Mapping' section. The 'check project' button is grayed out as well.

Aymeric.

0
Comment actions Permalink

Hello Aymeric,

Dmitry,

Thanks for looking into the issue. I already went through the steps
you described. When I click OK in the 'Configure VCS ...' window,
nothing happen I don't see any project listed under 'VSS Projects:' in
the 'Edit VCS Directory Mapping' section. The 'check project' button
is grayed out as well.

Aymeric.


For me "VSS projects" combobox also shows empty list. I manually enter valid
VSS project path (like $/superpath/projectpath) into the field, and the connection
works after that.

Alexander.


0
Comment actions Permalink

Thanks Alexander, that was the issue and it works properly now.
Not sure if that's how the UI should behave, but that setting was not obvious (at least to me),

Aymeric

0

Please sign in to leave a comment.