_svn folder for subversion in intellij

Hi,
Even I think my question must be asked before or there is trivial setting I couldn't find, I couldn't find the answer in google so I will ask here.
I have both Dot Net and Java proj using svn. So as a hack, I change svn folder from .svn to _svn. In eclipse it's fine with _svn. But in Intellij, the _svn shows up all the time and when I try to look for resource, any file in _svn shows up as read only. Is there any config or hack to make intellij recognize it's svn hidden folder and behave normally, such as ignoring any file in that folder? Thanks.


ying

7 comments
Comment actions Permalink

Hi ying,

You can add "_svn" to "Ignore files and folders" in Settings | General.

t800t8

0
Comment actions Permalink

that works. Thanks. But still think intelliJ svn integration should be done better. Eclipse svn doesn't need this kind of tweaking though.

0
Comment actions Permalink

I don't understand how the fact that you're using both DotNet and Java makes you wanting to alter how .svn into _svn ?

0
Comment actions Permalink

Hi Thibaut,

When you install Subversion (from EXE file) on Windows, it recommends you to change ".svn" to "_svn" if you want to develop ASP.NET. Maybe ASP.NET has some problems with folder which has name starts with a dot.

0
Comment actions Permalink

yes, with asp.net, this problem is well documented.

0
Comment actions Permalink

Thanks for the information, I wasn't aware of this

0
Comment actions Permalink

Then maybe the fix should take place in Dot Net rather than IntelliJ? Hard to see how Microsoft's bug is Jetbrain's problem.

0

Please sign in to leave a comment.