[generics] does Idea support static imports?

I want to compile some sources in Idea that contains generics style code. Among other things there's some static imports statements. Does Idea support it?

e.g.


And the COS class looks like:

10 comments
Comment actions Permalink

Daniel Moldovan wrote:

I want to compile some sources in Idea that contains generics style code.
Among other things there's some static imports statements. Does Idea
support it?


No, not yet. Probably not in Aurora...

Friendly,
Dmitry


e.g.



And the COS class looks like:

 
>   public static final Class CLASS_IREF=IRef.class;
>   public static final Class CLASS_DICTIONARY=Dict.class;
>   public static final Class CLASS_ARRAY=Object[].class;
>    ...........
> 
> }]]>


--
Dmitry Lomov
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

Dmitry Lomov (JetBrains) wrote:

Daniel Moldovan wrote:

>>I want to compile some sources in Idea that contains generics style code.
>>Among other things there's some static imports statements. Does Idea
>>support it?


No, not yet. Probably not in Aurora...


If I'm not mistaken, this is a Java Compiler change for JDK 1.5 which is not
out yet (not even a release candidate). It probably won't be supported until
that time.

0
Comment actions Permalink

I've downloaded adding_generics-2_2-ea.zip, set up Idea to use generic compiler and that code compiled succesfully in spite of the error syntax highlighting.
Am I missing somethig?

0
Comment actions Permalink

BTW, then JDK 1.5 released, will Aurora works with it correctly?
I mean that now IDEA use generics only from lib/generics folder, but for JDK
1.5 it not requires...
Is there any suggestions of this?
Thank you
--
Alexey Efimov, Software Engineer
Sputnik Labs,
http://www.spklabs.com
"Dmitry Lomov (JetBrains)" <Dmitry.Lomov@jetbrains.com> wrote in message
news:bksfgd$j6t$1@is.intellij.net...

Daniel Moldovan wrote:

>

I want to compile some sources in Idea that contains generics style

code.

Among other things there's some static imports statements. Does Idea
support it?

>

No, not yet. Probably not in Aurora...

>

Friendly,
Dmitry
>

e.g.


>

And the COS class looks like:

>

 >
> >   public static final Class CLASS_IREF=IRef.class;
> >   public static final Class CLASS_DICTIONARY=Dict.class;
> >   public static final Class CLASS_ARRAY=Object[].class;
> >    ...........
> >
> > }]]>

>

--
Dmitry Lomov
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"



0
Comment actions Permalink

Daniel Moldovan wrote:

I've downloaded adding_generics-2_2-ea.zip, set up Idea to use generic
compiler and that code compiled succesfully in spite of the error syntax
highlighting. Am I missing somethig?


Static imports are part of JSR014 2.2 EA release, but they are not (and not
likely to be) supported by Aurora.

Friendly,
Dmitry

--
Dmitry Lomov
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

Alexey Efimov wrote:

BTW, then JDK 1.5 released, will Aurora works with it correctly?
I mean that now IDEA use generics only from lib/generics folder, but for
JDK 1.5 it not requires...


As truly noted in the other message of this thread, 1.5 is not even in beta
yet. Obvious answer to your question is: IntelliJ IDEA is not going out of
this market any time soon, so we will keep up with all the latest Java
developements, including generics and static imports :)

For more specifics, wait until 1.5 is out - at least in beta. We cannot
guarantee that IDEA works with something that does not exist yet :)

Friendly,
Dmitry

--
Dmitry Lomov
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0
Comment actions Permalink

:) Thanks for reply

0
Comment actions Permalink

On Thu, 25 Sep 2003 13:47:38 +0400, Dmitry Lomov (JetBrains) wrote:

Static imports are part of JSR014 2.2 EA release, but they are not (and
not likely to be) supported by Aurora.


They won't be????

--
"It's all in the heat of the moment, it's all in the pain..." Devy.
Mark Derricutt @ mark@talios.com @ talios.blog-city.com
Now Playing: %s

0
Comment actions Permalink

Mark Derricutt wrote:

On Thu, 25 Sep 2003 13:47:38 +0400, Dmitry Lomov (JetBrains) wrote:

>>Static imports are part of JSR014 2.2 EA release, but they are not (and
>>not likely to be) supported by Aurora.


They won't be????


Think about it... How can they develop support for something that doesn't
exist in any publically accessible form yet? You gotta wait until JDK 1.5
is available.

0
Comment actions Permalink

On Thu, 25 Sep 2003 17:36:36 -0400, Berin Loritsch wrote:

Think about it... How can they develop support for something that doesn't
exist in any publically accessible form yet? You gotta wait until JDK 1.5
is available.


Ah ok - I've not actually looked at the generics compiler yet, I reset my
password on the java site but they never emailed me the password :( Grr.
And no amount of trying has solved that :(


0

Please sign in to leave a comment.