[New to Windows] problem in debug.

Hello,

I have been using IDEA on Solaris for a year now, but I needed to try
something on Win2k where I got some problems in debugging a very simple
program.

I am sure it is some trivial settings problem, but it is my first time
to develop java on win.

Problem:
Whenever I debug the program IDEA enters into ClassLoader and
URLClassLoader classes with exceptions that classes are not found .

Environment:
java 1.4.1_02
My source is on a Unix machine, mapped to a windows drive.
I tried to change the compile output path to a windows drive, but
nothing changed.
IDEA 929

Thank you in advance for your time and help.

--
Best Regards,
Mamado.


3 comments
Comment actions Permalink

Very strange...
Try to create new test project in IDEA on W2K platform. Create HelloWord
main class and try debug it. It must worked, if not, then maybe some
misconfigured problems in system.
Thanks!
PS. I have debug working fine on W2K and XP

--
Alexey Efimov, Software Engineer
Sputnik Labs,
http://www.spklabs.com
"Mamado" <mamado_inside_y@yahoo.com> wrote in message
news:bku6uh$9mn$1@is.intellij.net...

Hello,

>

I have been using IDEA on Solaris for a year now, but I needed to try
something on Win2k where I got some problems in debugging a very simple
program.

>

I am sure it is some trivial settings problem, but it is my first time
to develop java on win.

>

Problem:
Whenever I debug the program IDEA enters into ClassLoader and
URLClassLoader classes with exceptions that classes are not found .

>

Environment:
java 1.4.1_02
My source is on a Unix machine, mapped to a windows drive.
I tried to change the compile output path to a windows drive, but
nothing changed.
IDEA 929

>

Thank you in advance for your time and help.

>

--
Best Regards,
Mamado.

>
>


0
Comment actions Permalink

I've exactly the same problem.
JDK1.4.2_01, WinXPSp1, IDEA 929

Carsten

Mamado wrote:

Hello,

>

I have been using IDEA on Solaris for a year now, but I needed to
try something on Win2k where I got some problems in debugging a very
simple program.

>

I am sure it is some trivial settings problem, but it is my first
time to develop java on win.

>

Problem:
Whenever I debug the program IDEA enters into ClassLoader and
URLClassLoader classes with exceptions that classes are not found .

>

Environment:
java 1.4.1_02
My source is on a Unix machine, mapped to a windows drive.
I tried to change the compile output path to a windows drive,
but nothing changed.
IDEA 929

>

Thank you in advance for your time and help.



0
Comment actions Permalink

There is a global breakpoint (Any Breakpoint) at the Exception
breakpoint page.
You have several options:
1) disable the breakpoint (recommended) or
2) apply a condition || class filter for it.

The option "do not step into classes" of the project settings/debugger
page is not considered for breakpoints.

I hope it helps

Sven

Mamado wrote:

Hello,

I have been using IDEA on Solaris for a year now, but I needed to try
something on Win2k where I got some problems in debugging a very simple
program.

I am sure it is some trivial settings problem, but it is my first time
to develop java on win.

Problem:
Whenever I debug the program IDEA enters into ClassLoader and
URLClassLoader classes with exceptions that classes are not found .

Environment:
java 1.4.1_02
My source is on a Unix machine, mapped to a windows drive.
I tried to change the compile output path to a windows drive, but
nothing changed.
IDEA 929

Thank you in advance for your time and help.


0

Please sign in to leave a comment.