Error starting modern compiler... OutOfMemoryError

I had been using IntelliJ IDEA 7.0.3 for a few weeks, and I just got a new laptop. I copied my IDEA setup from my old laptop to this new one, but I am running into some problems.

When I run certain ant tasks from within idea, I get this "Error starting modern compiler", and an OutOfMemoryError. This ant task works fine when run directly from the command line.
Full error log is attached.

What might be the cause of this?

I have set a max memory size for IDEA(in idea.vmoptions) to about 1.5GB, so I don't think that is the issue.

The new laptop is running Ubuntu 8.04 "Hardy" 64-bit Linux with gnome desktop environment.

Edited by: hloeblich on Apr 19, 2008 2:50 AM


check your ant javac target: the target may say fork="yes", in which case it gets its own VM that does not inherit the 1.5GB you configured for IDEA


My the javac line in my build.xml looks like this:

fork attribute is not being set there. This same exact build.xml worked on my previous computer, I wonder if it's something about my java setup that is messed up. Also, my previous computer was 32bit linux, and this is 64bit.


Given the additional details you provided, agreed that my rsponse would not be correct. Sounds like a jvm/platform specific bug.


Well, I mentioned my problem to another person I work with, and they showed me that you can bump up the memory for the ant task by right clicking on the task and going to properties. I bumped it from 128 to 384 and now I can run that task that was giving me trouble. It's still a little odd, that I never had to do that on my old computer, but I'm just satisfied that it runs now.


I just reported a different bug(IDEA stability issues) to IntelliJ, and they informed me(very promptly I should mention :-D ) that 64bit JDK requires roughly twice as much heap. It's all starting to make sense. I had to increase my permgen space in idea.vmoptions to fix my stability issues.


Please sign in to leave a comment.