Newbie ?: java.lang.Double (and other types)not found although jdk defined

Hi,
I am running For IJ7.03 .. .

Getting hundreds of errors from basic JDK defined types and libraries including java.lang.Double, java.net.InetAddress, etc.

But I did set the JDK (6) for the project, and it shows up (along with rt.jar, jsse.jar, and a dozen or so other basic JDK jars) in the Project Settings | Platform Settigs | JDK's

So, what configuration step am I missing?

thanks,
steveb

3 comments
Comment actions Permalink

In addition to defining
1) the JDK in general: Project Settings -> Platform Settings -> JDKs
2) be sure that you also selected that JDK for the project: Project Settings -> Project Settings -> General -> Project JDK.
3) Also check the module specific JDK settings: Project Settings -> Project Settings -> Modules -> -> "Dependencies" tab ->]]> Module JDK

If all that lokks ok, then I am at a loss, also.

I complained more than once that 1) is very misleading, because it is a IDE-wide setting that is categorized as a project setting.

Stephen Boesch wrote:

Hi,
I am running For IJ7.03 .. .

Getting hundreds of errors from basic JDK defined types and libraries including java.lang.Double, java.net.InetAddress, etc.

But I did set the JDK (6) for the project, and it shows up (along with rt.jar, jsse.jar, and a dozen or so other basic JDK jars) in the Project Settings | Platform Settigs | JDK's

So, what configuration step am I missing?

thanks,
steveb

0
Comment actions Permalink

More information: when I go to "Make" the project, there is a message that a JDK has not been specified for the given module. However, when I go to the module settings and click on the Dependencies tab, the "Module JDK" says "Project JDK (1.6)" .

So the JDK for the module IS set. Any ideas what is going on here?

0
Comment actions Permalink

There was some more twiddling but Steve F's answer was in the basic ballpark.

Forum question: I can't see how to assign points to his answer.

Edited by: Stephen Boesch on Apr 19, 2008 11:49 PM

0

Please sign in to leave a comment.