Weblogic remote deployment problem in 7.0.3

Having a bit of a problem.

It used to be that if I attempted to deploy a war file that was already deployed on weblogic (9.2) the console would report an error that the application already existed and couldn't be deployed. It was easily solved by just hitting undeploy, waiting a second, and then redeploying.

It seems that a change happened recently where IntelliJ tried to fix that issue by automatically doing an undeploy before deploying the new application. The problem that I'm having however is that if the application has never been deployed to the application server or is undeployed in any fashion, trying to deploy remotely gives me this error:

<> <> <> <> ]]>
com.intellij.javaee.weblogic.runDebug.weblogicServerInstances.version9.mbeansModel.JMWrappedException: javax.management.MBeanException: MBean invoke failed: weblogic.management.ManagementException: No application named 'DirectoriesWeb' exists for operation undeploy
at com.intellij.javaee.weblogic.runDebug.weblogicServerInstances.version9.mbeansModel.AbstractWL9MBean.invoke(AbstractWL9MBean.java:85)
...

Basically I have to go into the Weblogic console and manually deploy it through that in order for deployment to work again in IDEA. Has anyone else run into this issue? Does anyone have any suggestions or ideas or should I submit this to JIRA?

Thanks,
~Colin

Please sign in to leave a comment.