weblogic will not start

Hi,

I'm at a loss, I've screwed up something so that my weblogic server will not start anymore from IntelliJ. The error I get in IntelliJ's console window is:

-


Starting WLS with line:
/home/ericm/bea/jrockit90_150_06/bin/java -jrockit -Xms256m -Xmx512m -Xdebug -Xrunjdwp:transport=dt_socket,address=127.0.0.1:40737,suspend=y,server=n -Xverify:none -da -Dplatform.home=/home/ericm/bea/weblogic92 -Dwls.home=/home/ericm/bea/weblogic92/server -Dwli.home=/home/ericm/bea/weblogic92/integration -Dweblogic.management.discover=true -Dwlw.iterativeDev= -Dwlw.testConsole= -Dwlw.logErrorsToConsole= -Dweblogic.ext.dirs=/home/ericm/bea/patch_weblogic921/profiles/default/sysext_manifest_classpath -Dweblogic.Name=AdminServer -Djava.security.policy=/home/ericm/bea/weblogic92/server/lib/weblogic.policy weblogic.Server

Unknown option or illegal argument: -jrockit .
Please check for incorrect spelling or review documentation of startup options.

-



- When I start my weblogic server using the startWeblogic.sh file from the terminal it comes up just fine
- I'm using a local connection configuration in IntelliJ to run weblogic
- I've removed and readded the weblogic configuration several times
- when I remove the -jrockit option from the java invocation line in the startup script, it then complains about the next switch in the line.
- I'm running on UBUNTU linux.
- I've copied over another developer's startWeblogic.sh file, and I get the same problem, so I don't think that there are special characters in the startup script.
- I've uninstalled intelliJ and tried using it from another spot, same problem.
- I've also reinstalled weblogic and tried pointing to the new install from intellij, same problem.

I know this is cryptic, but has anyone else gotten themselves into this situation before?

Thanks,
Eric

2 comments
Comment actions Permalink

Hello,

is domain path correctly specified in your WebLogic run configuration?
IDEA runs startWebLogic.sh script located in the directory specified in
"Domain path" field in run configuration.

Hi,

I'm at a loss, I've screwed up something so that my weblogic server will not start anymore from IntelliJ. The error I get in IntelliJ's console window is:

-----
Starting WLS with line:
/home/ericm/bea/jrockit90_150_06/bin/java -jrockit -Xms256m -Xmx512m -Xdebug -Xrunjdwp:transport=dt_socket,address=127.0.0.1:40737,suspend=y,server=n -Xverify:none -da -Dplatform.home=/home/ericm/bea/weblogic92 -Dwls.home=/home/ericm/bea/weblogic92/server -Dwli.home=/home/ericm/bea/weblogic92/integration -Dweblogic.management.discover=true -Dwlw.iterativeDev= -Dwlw.testConsole= -Dwlw.logErrorsToConsole= -Dweblogic.ext.dirs=/home/ericm/bea/patch_weblogic921/profiles/default/sysext_manifest_classpath -Dweblogic.Name=AdminServer -Djava.security.policy=/home/ericm/bea/weblogic92/server/lib/weblogic.policy weblogic.Server

Unknown option or illegal argument: -jrockit .
Please check for incorrect spelling or review documentation of startup options.

----

- When I start my weblogic server using the startWeblogic.sh file from the terminal it comes up just fine
- I'm using a local connection configuration in IntelliJ to run weblogic
- I've removed and readded the weblogic configuration several times
- when I remove the -jrockit option from the java invocation line in the startup script, it then complains about the next switch in the line.
- I'm running on UBUNTU linux.
- I've copied over another developer's startWeblogic.sh file, and I get the same problem, so I don't think that there are special characters in the startup script.
- I've uninstalled intelliJ and tried using it from another spot, same problem.
- I've also reinstalled weblogic and tried pointing to the new install from intellij, same problem.

I know this is cryptic, but has anyone else gotten themselves into this situation before?

Thanks,
Eric



--
Nikolay Chashnikov
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Dear Nikolay,

I'm sorry I just figured this out last night, I should have updated the thread right then. Apparently it was an issue with my window manager in linux (I use enlightenment). I kept messing with the IntelliJ weblogic startup and noticed that it would work fine in other window managers like fluxbox & gnome. Sorry to waste your time reading this, but I appreciate your help. Problem solved.

Regards,
Eric

P.S. The problem was I had made some specific settings to the IntelliJ window through enlightenment, and when I removed the enlightenment configuration from the IntelliJ window, everything started working again. I don't know the inner workings of enlightenment - but you can change/remember things on a window such as: border style, position, desktop location, etc...

0

Please sign in to leave a comment.