project migration with builds

With each and every build of the EAP that I try (starting in the 800s
and until now with 915), I get the warning that my original project may
be in an older format and will need to be updated. I do so, and the
project comes out to have all its settings wiped out.

Surely I'm doing something wrong. Or does each build of the EAP really
require a creation of the project from scratch? The project I would like
to work on is quite big and project creation time becomes a deterrent
against trying EAPs.

What could I be doing wrong?

Sumit.

4 comments
Comment actions Permalink

Surely I'm doing something wrong. Or does each build of the EAP really
require a creation of the project from scratch?


No. The project file format hasn't changed significantly since #815.

What could I be doing wrong?


No idea.

Have you tried a clean new start: clean the system cache, remove the project
files, remove the idea config files ?



0
Comment actions Permalink

Sumit Kishore wrote:

What could I be doing wrong?



No idea, it should works fine.

If you don't do it yet, you could try clean-installing each new build in
a new directory
ex:
C:\dev\Tool\idea-915\

This way, when a build doesn't work for you, you can easily revert to
the previous one.
Hope this help.


Alain

0
Comment actions Permalink

I always install a new build in a new path, let IDEA store its settings in a subdirectory below the installation path (as opposed to the "user.home" option) and choose the option to import settings from a previous installation. This way I never had any problems opening and working with my existing projects.

Thomas Gülden
Munich, Germany

0
Comment actions Permalink

I do suspect this has nothing to cleaning caches or performing "clean"
install. As the matter of fact current IDEA just does not support (yet)
convertion of project files created by IDEA version < 812 or something. Thus
you need to create your project from the scratch until conversion tool
appears. On other hand project file created by IDEA # >812 should be opened
by 915 without any additional questions and attempts to convert something.
Please ensure you're openening "new" project, not the one created by 3.0.x.
If the problem persist this way, please file a bug.

Thanks.

--

Best regards,
Maxim Shafirov
JetBrains, Inc / IntelliJ Software
http://www.intellij.com
"Develop with pleasure!"


"Sumit Kishore" <sumitkishore@hotpop.com> wrote in message
news:bjbabl$5hv$1@is.intellij.net...

With each and every build of the EAP that I try (starting in the 800s
and until now with 915), I get the warning that my original project may
be in an older format and will need to be updated. I do so, and the
project comes out to have all its settings wiped out.

>

Surely I'm doing something wrong. Or does each build of the EAP really
require a creation of the project from scratch? The project I would like
to work on is quite big and project creation time becomes a deterrent
against trying EAPs.

>

What could I be doing wrong?

>

Sumit.

>


0

Please sign in to leave a comment.