deploying applicaton on Tomcat from IDEA on Mac OS X

Hello,

It's strange but I have following problem. When I try to deploy my application on Tomcat from IDEA I have following error:
-


/Library/Tomcat/bin/catalina.sh run
Exception in thread "main" java.lang.NoClassDefFoundError: Application8f89284d/conf/logging/properties
Disconnected from server
-


I've checked IDEA caches and I have
/User/username/Library/Caches/IntelliJIDEA70/tomcat__AppName Application8f89284d/conf/logging.properties file.

I've tried to install Tomcat in different places but without any success.

I configure Tomcat as local server. I haven't had any problem with such configuration on Windows but have this error on Mac OS X.

I use IDEA 7.0.2 build 7590 and Java 1.5.0.13 on Mac OS X Leopard 10.5.1.

Any ideas how to resolve this problem?

Thanks,
Siarhei Barysiuk

1 comment
Comment actions Permalink

The answer is simple - I have a space in name of project, e.g. 'App Name' and IDEA generated folder for Tomcat files with space.

The problem is solved.

Bye,
Siarhei

0

Please sign in to leave a comment.