7.0.2 can't remove file types

I somehow got some odd entries in my file types, but I can't remove them.

I'm on a Mac, Leopard.

I go to prefs, File Types, Java Source Files. In the bottom Pane I see:
*.java
*.wtf
CompleteOrderAction
CompleteOrderAction.java

I want to remove the bottom 3, so I click them and hit remove. Visually they are now gone, but hte Apply button does not highlight. I press ok. Go back, they are there again.. haunting me. this occurs for Java class files, java source files, jsps, and xml (the ones I tested it on).

Help! It won't code color or help at all on my CompleteOrderAction class!

2 comments

Hello Brett,

Exit IDEA, go to {User.home}/.IntelliJIdea70/config/options/filetypes.xml,
remove superfluous entries (this xml structure is quite intuitive) and restart.

There are a number of issues in JIRA about this and related bugs:
http://www.jetbrains.net/jira/browse/IDEADEV-23885
http://www.jetbrains.net/jira/browse/IDEA-16839

I somehow got some odd entries in my file types, but I can't remove
them.

I'm on a Mac, Leopard.

I go to prefs, File Types, Java Source Files. In the bottom Pane I
see:
*.java
*.wtf
CompleteOrderAction
CompleteOrderAction.java
I want to remove the bottom 3, so I click them and hit remove.
Visually they are now gone, but hte Apply button does not highlight. I
press ok. Go back, they are there again.. haunting me. this occurs for
Java class files, java source files, jsps, and xml (the ones I tested
it on).

Help! It won't code color or help at all on my CompleteOrderAction
class!

Alexander.


0

For me, it was in:

~/Library/Preferences/IntellijIDEA70/options/filetypes.xml, but after that you were spot on!

You sir, are a gentleman and a scholar. Thanks.

0

Please sign in to leave a comment.