Help on Optimize Imports...

I have enabled the "Optimize Imports on the fly" and now I can't turn it off. How/where do I go in the IDE to turn it off? There are times when I have imports with comments, and the optimize is wiping out the comment. Also, each time I open a file now, it optimizes the imports, which causes issues with the source repository.

HELP!

Thanks,

a new IDEA user

2 comments

Hello Gil,

It's in the code style/imports tab. Go to settings, project code style (and
click global if that's what you're using) and chech the imports tab.

(BTW, the search function on the settings panel is quite useful, you should
give it a try for cases like this.)

HTH,
Andrei

I have enabled the "Optimize Imports on the fly" and now I can't turn
it off. How/where do I go in the IDE to turn it off? There are times
when I have imports with comments, and the optimize is wiping out the
comment. Also, each time I open a file now, it optimizes the imports,
which causes issues with the source repository.

HELP!

Thanks,

a new IDEA user



0

Thanks for the response. It was actually on the Settings->Editor->Behavior tab.

Thanks again!

0

Please sign in to leave a comment.