Can't include project dir in classpath

We haven't been able to include the project directory in the classpath of our project with either 876 or 887. It works as we expect it to in 873, but the subsequent builds cause all kinds of problems with package paths in the editor if you include the project dir in the "Libraries" panel of the Main Module preferences in Project Properties.

Our source is in a sub-dir of the project dir called "src" and after the project dir is included in the Libraries, IDEA starts prepening the "src/" dir to where it expects to look to locate imported classes, etc. Very troubling, and causing us to have to use 873 until a new build comes out that works again.

Thanks,
Rick Ross
rick@javalobby.org

3 comments
Comment actions Permalink

IDEA starts prepening the "src/" dir to where it expects to look to locate

imported classes, etc.

What do you mean? Which behaviour you see exactly?

--
Valentin Kipiatkov
JetBrains, Inc
http://www.intellij.com
"Develop with pleasure!"


"Rick Ross" <no_mail@jetbrains.com> wrote in message
news:27420914.1060431990453.JavaMail.itn@is.intellij.net...

We haven't been able to include the project directory in the classpath of

our project with either 876 or 887. It works as we expect it to in 873, but
the subsequent builds cause all kinds of problems with package paths in the
editor if you include the project dir in the "Libraries" panel of the Main
Module preferences in Project Properties.
>

Our source is in a sub-dir of the project dir called "src" and after the

project dir is included in the Libraries, IDEA starts prepening the "src/"
dir to where it expects to look to locate imported classes, etc. Very
troubling, and causing us to have to use 873 until a new build comes out
that works again.
>

Thanks,
Rick Ross
rick@javalobby.org



0
Comment actions Permalink

What we're seeing is that if you include the Project path in as a Library (to add it to the classpath), when you open a source file, the package statement is underlined red and IntelliJ tells us that it is in the wrong package (ie. it should be src.com.test instead of com.test). This worked in earlier versions and is needed if you have things such as properties files or loading images as resources. Simply setting the working directory to the project path does not work.

-Matt

0
Comment actions Permalink

Matthew Schmidt wrote:

What we're seeing is that if you include the Project path in as a Library
(to add it to the classpath), when you open a source file, the package
statement is underlined red and IntelliJ tells us that it is in the wrong
package (ie. it should be src.com.test instead of com.test). This worked
in earlier versions and is needed if you have things such as properties
files or loading images as resources. Simply setting the working
directory to the project path does not work.

-Matt


Please submit a report to Tracker.

Friendy,
Dmitry
--
Dmitry Lomov
IntelliJ Labs / JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

Please sign in to leave a comment.