Debugger not stopping at breakpoints after first time

I'm not sure where to post this but it's happening with debugging in Tomcat so I guess I'll try this forum. Here is the relevant information:

- Idea build: 7531
- Intellij Java version: 1.6.0_03
- Project created from "new project wizard" based off a maven file using regular Intellij Idea modules, not temporary ones.
- Tomcat 6.0.14
- Tomcat Java version: 1.5.0_12

Here's the problem, and I swear it just started and have no idea why. I run my application using an exploded webapp directory that Idea creates and the built in "deploy to local Tomcat" run configuration functionality. When I run in debug mode, breakpoints will pop the very first time they are hit, but then... nothing. They wont' be hit again. I can insert a simple System.out.println() and see that the code I have marked is being run every time but the breakpoints just aren't stopping.

When I revert back to Idea 6.0.6, everything works fine, however I have been using 7.0.1 and 7.0.2(EAP) for a while without problems.

I've searched the tracker and didn't see anything about his issue so I hope I just have something misconfigured. I don't see how it could be related, but I noticed this happening at about the same time as another issue I reported here: http://intellij.net/forums/thread.jspa?threadID=271239

Matt

3 comments

I discovered what was causing this issue. In another project that I was working on, I was using Javarebel for class reloading and I had the Javarebel Debugger plugin installed. Well, apparently, if you have that plugin installed but aren't actually using Javarebel in your run configuration, then you can run into the issue I described. Removing the Javarebel Debugger plugin solved this problem.

0

There is a new version of the plugin available (either use the update site or here is the link http://plugins.intellij.net/plugin/?id=1699). This should fix your issue.

0

Great! I look forward to giving it a try again.

0

Please sign in to leave a comment.