Can't install Build 856.

I receive this error right after the aurora logo comes up:
"This application has suddendly quit." I receive a LAX error and then details are:

java.lang.ArrayIndexOutOfBoundsException: 0
at com.zerog.ia.installer.Main.j(Unknown Source)
at com.zerog.ia.installer.Main.e(Unknown Source)
at com.zerog.ia.installer.Main.b(Unknown Source)
at com.zerog.ia.installer.Main.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.zerog.lax.LAX.launch(Unknown Source)
at com.zerog.lax.LAX.main(Unknown Source)



Attachment(s):
install_error856.png
8 comments
Comment actions Permalink

Oh, also.. My setup is:

Windows 2003 Server with JDK 1.4.2 already installed on the system.

--Grant

0
Comment actions Permalink

On WinXP all is working well.

Who has the same problem?



"Grant Gochnauer" <ggochnauer@braunconsult.com> wrote in message
news:19001943.1057758397760.JavaMail.javamailuser@localhost...

I receive this error right after the aurora logo comes up:
"This application has suddendly quit." I receive a LAX error and then

details are:
>

java.lang.ArrayIndexOutOfBoundsException: 0
at com.zerog.ia.installer.Main.j(Unknown Source)
at com.zerog.ia.installer.Main.e(Unknown Source)
at com.zerog.ia.installer.Main.b(Unknown Source)
at com.zerog.ia.installer.Main.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.zerog.lax.LAX.launch(Unknown Source)
at com.zerog.lax.LAX.main(Unknown Source)



0
Comment actions Permalink

Worked fine for me here on Win2K. I installed the 856.exe into a new
directory, importing my previous settings (from 833).

"Stanislav Davydov" <stathik@intellij.com> wrote in message
news:beh8gf$1tu$1@is.intellij.net...

On WinXP all is working well.

>

Who has the same problem?

>
>
>

"Grant Gochnauer" <ggochnauer@braunconsult.com> wrote in message
news:19001943.1057758397760.JavaMail.javamailuser@localhost...

I receive this error right after the aurora logo comes up:
"This application has suddendly quit." I receive a LAX error and then

details are:
>

java.lang.ArrayIndexOutOfBoundsException: 0
at com.zerog.ia.installer.Main.j(Unknown Source)
at com.zerog.ia.installer.Main.e(Unknown Source)
at com.zerog.ia.installer.Main.b(Unknown Source)
at com.zerog.ia.installer.Main.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.zerog.lax.LAX.launch(Unknown Source)
at com.zerog.lax.LAX.main(Unknown Source)

>
>


0
Comment actions Permalink

Oh, also.. My setup is:

Windows 2003 Server with JDK 1.4.2 already installed
on the system.

--Grant


Hello,
I had the same problem (I'm running Win 2003+JDK 1.4.2). I right clicked on the .exe file and selected XP compatibility mode. Then it works. This has never happened to me before with the ZeroG installer!. But this was b.t.w. build 855 wich was quickly replaced by build 856 :-).

Burkni

0
Comment actions Permalink

Oh awesome.

I just finished with my work around.

I downloaded the zip version, unzipped it into my intelliJ directory, unzipped the installer exe file, copied that jre into the directory I just made for the zip and then manually edited the idea.bat file :)

--Grant

0
Comment actions Permalink

I have a different install problem.

After downloading the windows.exe version, I double clicked it. Went through the extraction process, but when it finished (reached 99%), it showed an alert box asking me to choose another location to extract the installer to. No matter what directory I subsequently chose, it would repeat the same sequence of events.

Win 2k, sp3. Plenty of hard drive space free.

Off to try the zip versions...

0
Comment actions Permalink

After downloading the windows.exe version, I double
clicked it. Went through the extraction process, but
when it finished (reached 99%), it showed an alert
box asking me to choose another location to extract
the installer to. No matter what directory I
subsequently chose, it would repeat the same sequence
of events.


Hi Peter,

I have also encountered this behavior quite frequently with a number of builds. In many cases (e.g. in the case of build 856) what works is to NOT close that dialog, find a newly created subdirectory of the system TEMP dir (normally named "I]]>"), go into its "Windows" subdirectory and execute the "install.exe" there (do NOT release the installer dialog during the installation because that will delete the temp dir).

Good luck,
Jens

P.S.: I don't know whether this behavior is caused by corrupt install files (we have a very ill-behaved proxy server here in our company which frequently corrupts downloaded files) or whether it's just my machine that's weird.

0
Comment actions Permalink

thanks for the tip.

This is the first build this has happened to me, and I am behind a proxy. Stupid computers. ;o)

0

Please sign in to leave a comment.