1.4.2 problem

Hi.

This is unrelated to IntelliJ (I think) but I hope someone will verify or
know about this problem:

I have 3 classes: Element, InlayScript and Page. Both Page and InlayScript
extend Element, and InlayScript is a protected inner class of Element.

I am instantiating an InlayScript in a method of Page.

Under 1.4.1_03, everything compiles and runs.
If I compile with 1.4.1_03 and run under 1.4.2 it works fine.
If I compile with 1.4.2 and try to run under 1.4.2 I get this error:
java.lang.VerifyError: (class: com/freshwater/element/Element$InlayScript,
method: ]]> signature:
(Lcom/freshwater/element/Element;Ljava/lang/String;)V) Expecting to find
object/array on stack

The constructor of InlayScript is not called (I tried to set a breakpoint in
the 1st line of it).

Has anyone else encountered this?

Can anyone shed some light?

Thanks,
Amnon



Please sign in to leave a comment.