7.0 does not recognize standard java classes

I am sure this is something simple I have overlooked but anyway...

I Installed 7.0 an loaded up my plugin project. Everything was red so I created a new plugin jdk and assigned it as the jdk used by my project. Idea still does not recognize standard Java classes such as swing. Still red...
Why?

11 comments
Comment actions Permalink

Hello Johan,

What java platform did you choose?

Thank you

-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

I am sure this is something simple I have overlooked but anyway...

I Installed 7.0 an loaded up my plugin project. Everything was red so
I created a new plugin jdk and assigned it as the jdk used by my
project. Idea still does not recognize standard Java classes such as
swing. Still red...

Why?



0
Comment actions Permalink

I am on a Windows machine. I only get the option to choose 1.6.

Hello Johan,

What java platform did you choose?

Thank you

---------------------
Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

>> I am sure this is something simple I have overlooked but anyway...
>>
>> I Installed 7.0 an loaded up my plugin project. Everything was red so
>> I created a new plugin jdk and assigned it as the jdk used by my
>> project. Idea still does not recognize standard Java classes such as
>> swing. Still red...
>>
>> Why?
>>


0
Comment actions Permalink

Hello Johan,

Is it valid 1.6 installation? Seems that your jdk doesn't contain classes
from java platform

Thank you
-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

I am on a Windows machine. I only get the option to choose 1.6.

>> Hello Johan,
>>
>> What java platform did you choose?
>>
>> Thank you
>>
>> -


>> Anna Kozlova
>> JetBrains Inc.
>> http://www.intellij.com
>> "Develop with pleasure!"
>>> I am sure this is something simple I have overlooked but anyway...
>>>
>>> I Installed 7.0 an loaded up my plugin project. Everything was red
>>> so I created a new plugin jdk and assigned it as the jdk used by my
>>> project. Idea still does not recognize standard Java classes such as
>>> swing. Still red...
>>>
>>> Why?
>>>


0
Comment actions Permalink

Its a plugin jdk not a standard java jdk.
When it prompts me to select the jdk folder I point it to the "Program Files\Jet
Brains\IntelliJ IDEA 7.0" folder.
It then says "IDEA 7361 (java version 1.6.0_02)" under project JDK.

Hello Johan,

Is it valid 1.6 installation? Seems that your jdk doesn't contain
classes from java platform

Thank you
---------------------
Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

>> I am on a Windows machine. I only get the option to choose 1.6.
>>
>>> Hello Johan,
>>>
>>> What java platform did you choose?
>>>
>>> Thank you
>>>
>>> -


>>> Anna Kozlova
>>> JetBrains Inc.
>>> http://www.intellij.com
>>> "Develop with pleasure!"
>>>> I am sure this is something simple I have overlooked but anyway...
>>>>
>>>> I Installed 7.0 an loaded up my plugin project. Everything was red
>>>> so I created a new plugin jdk and assigned it as the jdk used by my
>>>> project. Idea still does not recognize standard Java classes such
>>>> as swing. Still red...
>>>>
>>>> Why?
>>>>


0
Comment actions Permalink

Johan,

Which build do you run? IDEA 7.0 asks about which java version would you
use as java platform (due to dual build).

Thank you

-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

Its a plugin jdk not a standard java jdk.
When it prompts me to select the jdk folder I point it to the "Program
Files\Jet
Brains\IntelliJ IDEA 7.0" folder.
It then says "IDEA 7361 (java version 1.6.0_02)" under project JDK.

>> Hello Johan,
>>
>> Is it valid 1.6 installation? Seems that your jdk doesn't contain
>> classes from java platform
>>
>> Thank you
>> -


>> Anna Kozlova
>> JetBrains Inc.
>> http://www.intellij.com
>> "Develop with pleasure!"
>>> I am on a Windows machine. I only get the option to choose 1.6.
>>>
>>>> Hello Johan,
>>>>
>>>> What java platform did you choose?
>>>>
>>>> Thank you
>>>>
>>>> -


>>>> Anna Kozlova
>>>> JetBrains Inc.
>>>> http://www.intellij.com
>>>> "Develop with pleasure!"
>>>>> I am sure this is something simple I have overlooked but anyway...
>>>>>
>>>>> I Installed 7.0 an loaded up my plugin project. Everything was red
>>>>> so I created a new plugin jdk and assigned it as the jdk used by
>>>>> my project. Idea still does not recognize standard Java classes
>>>>> such as swing. Still red...
>>>>>
>>>>> Why?
>>>>>


0
Comment actions Permalink

I use IDEA build 7361 and it did indeed popup a dialog that let me choose
which Java version to use.
I only get the 1.6 choice though. It is impossible to choose 1.5.

Johan,

Which build do you run? IDEA 7.0 asks about which java version would
you use as java platform (due to dual build).

Thank you

---------------------
Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

>> Its a plugin jdk not a standard java jdk.
>> When it prompts me to select the jdk folder I point it to the
>> "Program
>> Files\Jet
>> Brains\IntelliJ IDEA 7.0" folder.
>> It then says "IDEA 7361 (java version 1.6.0_02)" under project JDK.
>>> Hello Johan,
>>>
>>> Is it valid 1.6 installation? Seems that your jdk doesn't contain
>>> classes from java platform
>>>
>>> Thank you
>>> -


>>> Anna Kozlova
>>> JetBrains Inc.
>>> http://www.intellij.com
>>> "Develop with pleasure!"
>>>> I am on a Windows machine. I only get the option to choose 1.6.
>>>>
>>>>> Hello Johan,
>>>>>
>>>>> What java platform did you choose?
>>>>>
>>>>> Thank you
>>>>>
>>>>> -


>>>>> Anna Kozlova
>>>>> JetBrains Inc.
>>>>> http://www.intellij.com
>>>>> "Develop with pleasure!"
>>>>>> I am sure this is something simple I have overlooked but
>>>>>> anyway...
>>>>>>
>>>>>> I Installed 7.0 an loaded up my plugin project. Everything was
>>>>>> red so I created a new plugin jdk and assigned it as the jdk used
>>>>>> by my project. Idea still does not recognize standard Java
>>>>>> classes such as swing. Still red...
>>>>>>
>>>>>> Why?
>>>>>>


0
Comment actions Permalink

Any ideas Anna?
/J

I use IDEA build 7361 and it did indeed popup a dialog that let me
choose
which Java version to use.
I only get the 1.6 choice though. It is impossible to choose 1.5.

>> Johan,
>>
>> Which build do you run? IDEA 7.0 asks about which java version would
>> you use as java platform (due to dual build).
>>
>> Thank you
>>
>> -


>> Anna Kozlova
>> JetBrains Inc.
>> http://www.intellij.com
>> "Develop with pleasure!"
>>> Its a plugin jdk not a standard java jdk.
>>> When it prompts me to select the jdk folder I point it to the
>>> "Program
>>> Files\Jet
>>> Brains\IntelliJ IDEA 7.0" folder.
>>> It then says "IDEA 7361 (java version 1.6.0_02)" under project JDK.
>>>> Hello Johan,
>>>>
>>>> Is it valid 1.6 installation? Seems that your jdk doesn't contain
>>>> classes from java platform
>>>>
>>>> Thank you
>>>> -


>>>> Anna Kozlova
>>>> JetBrains Inc.
>>>> http://www.intellij.com
>>>> "Develop with pleasure!"
>>>>> I am on a Windows machine. I only get the option to choose 1.6.
>>>>>
>>>>>> Hello Johan,
>>>>>>
>>>>>> What java platform did you choose?
>>>>>>
>>>>>> Thank you
>>>>>>
>>>>>> -


>>>>>> Anna Kozlova
>>>>>> JetBrains Inc.
>>>>>> http://www.intellij.com
>>>>>> "Develop with pleasure!"
>>>>>>> I am sure this is something simple I have overlooked but
>>>>>>> anyway...
>>>>>>>
>>>>>>> I Installed 7.0 an loaded up my plugin project. Everything was
>>>>>>> red so I created a new plugin jdk and assigned it as the jdk
>>>>>>> used by my project. Idea still does not recognize standard Java
>>>>>>> classes such as swing. Still red...
>>>>>>>
>>>>>>> Why?
>>>>>>>


0
Comment actions Permalink

Hello Johan,

Please check that 1.6 jdk contains valid urls. If it is not the case please
attach jdk.table.xml in USER_HOME\Intellij Idea 7.0\config\options then I
would be able make a dicision.

Thank you

-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

Any ideas Anna?
/J

>> I use IDEA build 7361 and it did indeed popup a dialog that let me
>> choose
>> which Java version to use.
>> I only get the 1.6 choice though. It is impossible to choose 1.5.
>>> Johan,
>>>
>>> Which build do you run? IDEA 7.0 asks about which java version would
>>> you use as java platform (due to dual build).
>>>
>>> Thank you
>>>
>>> -


>>> Anna Kozlova
>>> JetBrains Inc.
>>> http://www.intellij.com
>>> "Develop with pleasure!"
>>>> Its a plugin jdk not a standard java jdk.
>>>> When it prompts me to select the jdk folder I point it to the
>>>> "Program
>>>> Files\Jet
>>>> Brains\IntelliJ IDEA 7.0" folder.
>>>> It then says "IDEA 7361 (java version 1.6.0_02)" under project JDK.
>>>>> Hello Johan,
>>>>>
>>>>> Is it valid 1.6 installation? Seems that your jdk doesn't contain
>>>>> classes from java platform
>>>>>
>>>>> Thank you
>>>>> -


>>>>> Anna Kozlova
>>>>> JetBrains Inc.
>>>>> http://www.intellij.com
>>>>> "Develop with pleasure!"
>>>>>> I am on a Windows machine. I only get the option to choose 1.6.
>>>>>>
>>>>>>> Hello Johan,
>>>>>>>
>>>>>>> What java platform did you choose?
>>>>>>>
>>>>>>> Thank you
>>>>>>>
>>>>>>> -


>>>>>>> Anna Kozlova
>>>>>>> JetBrains Inc.
>>>>>>> http://www.intellij.com
>>>>>>> "Develop with pleasure!"
>>>>>>>> I am sure this is something simple I have overlooked but
>>>>>>>> anyway...
>>>>>>>>
>>>>>>>> I Installed 7.0 an loaded up my plugin project. Everything was
>>>>>>>> red so I created a new plugin jdk and assigned it as the jdk
>>>>>>>> used by my project. Idea still does not recognize standard Java
>>>>>>>> classes such as swing. Still red...
>>>>>>>>
>>>>>>>> Why?
>>>>>>>>


0
Comment actions Permalink

Here is the file you requested.
Thanks
/J



Attachment(s):
jdk.table.xml
0
Comment actions Permalink

Johan,

Please add valid JSDK with name 1.6. Your IDEA SDK must have jars from JSDK
as well.


-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

Here is the file you requested.
Thanks
/J



0
Comment actions Permalink

Thanks Anna!

After som fiddeling I managed to get it to work.
I used to have a 1.6 jdk registered in IDEA but it was empty so I deleted it.
When I tried to make a new one I accidentally pointed it to my jre1.6.0_02.
Unfortunately IDEA accepted this as a valid JDK and I ended up with an empty
1.6.
But now it works :)

/JL

Johan,

Please add valid JSDK with name 1.6. Your IDEA SDK must have jars from
JSDK as well.

---------------------
Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

>> Here is the file you requested.
>> Thanks
>> /J


0

Please sign in to leave a comment.