IDEA 7.0 OS X startup failure

Hi, I installed build 7361 (7.0 release) on a fully updated Macbook, and I never get anything other than a bare menu after installing to the Applications folder. I've also tried running idea.sh from the command line, and this is what I get in the logs:

2007-10-16 07:13:51,992 ERROR - llij.ide.plugins.PluginManager - JDK:
1.5.0_07
2007-10-16 07:13:51,992 ERROR - llij.ide.plugins.PluginManager - VM:
Java HotSpot(TM) Client VM
2007-10-16 07:13:51,992 ERROR - llij.ide.plugins.PluginManager - Vend
or: Apple Computer, Inc.
2007-10-16 07:13:51,992 ERROR - llij.ide.plugins.PluginManager - OS:
Mac OS X
2007-10-16 07:13:51,993 ERROR - llij.ide.plugins.PluginManager -
java.lang.IllegalArgumentException: Missing extension point: com.intellij.errorH
andler in area null
at com.intellij.openapi.extensions.impl.ExtensionsAreaImpl.getExtensionP
ointImpl(ExtensionsAreaImpl.java:366)
at com.intellij.openapi.extensions.impl.ExtensionsAreaImpl.getExtensionP
oint(ExtensionsAreaImpl.java:353)
at com.intellij.diagnostic.IdeErrorsDialog.getSubmitter(IdeErrorsDialog.
java:73)
at com.intellij.diagnostic.DefaultIdeaErrorLogger.canHandle(DefaultIdeaE
rrorLogger.java:12)
at com.intellij.diagnostic.DialogAppender.appendToLoggers(DialogAppender
.java:24)
at com.intellij.diagnostic.DialogAppender$1.run(DialogAppender.java:9)

this error (including the diagnostic info about the JVM) appears to be repeated endlessly. I got a similar result when I tried to install on Linux (jdk 1.6.0_02 amd64)

Message was edited by:
adam_c

1 comment

Replying to self: in a thread about a similar issue with build 7424, I saw:

"add -Doldlicenseserver to VMOptions in Info.plist for now."

I did this and got the license screen and after entering my key, eventually into the application.

This is the first time I've installed IDEA on this system; it looks like the kind of scenario that needs to be added to the test suite before pushing out a production build.

Message was edited by:
adam_c

0

Please sign in to leave a comment.