Why don't you fix bug with multiple datasources in struts-config.xml?

I think it would be fixed in 7
but milestone 2 still have this bug :(

4 comments
Comment actions Permalink

Hello Mishael,

I think it would be fixed in 7
but milestone 2 still have this bug :(


Which bug would that be, and where's the JIRA issue for it?

--
Dmitry Jemerov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com/
"Develop with Pleasure!"


0
Comment actions Permalink

bug is very simple: just try to create 2 datasources in struts-config.xml
they will be highlighted red

jira: http://www.jetbrains.net/jira/browse/STRUTS-150

0
Comment actions Permalink

The given example

<?xml version="1.0" encoding="windows-1251"?>
<!DOCTYPE struts-config PUBLIC
"-//Apache Software Foundation//DTD Struts Configuration 1.2//EN"
"http://struts.apache.org/dtds/struts-config_1_2.dtd">
<struts-config>
<data-sources>
<data-source key="LALA" type="org.apache.commons.dbcp.BasicDataSource">
<set-property property="driverClassName"
value="oracle.jdbc.driver.OracleDriver"/>
<set-property property="url"
value="jdbc:oracle:thin:@192.168.1.1:1521:LALA"/>
</data-source>

<data-source key="BLABLA" type="org.apache.commons.dbcp.BasicDataSource">
<set-property property="driverClassName" value="com.ibm.db2.jcc.DB2Driver"/>
<set-property property="url" value="jdbc:db2://192.168.1.1:50000/blabla"/>
</data-source>
</data-sources>

is green for me. Which build do you use?


0
Comment actions Permalink

ups

very strange
it's green

my colleague install 7M2 yesterday
and i saw this bug with my own yeys
bt unfortunately, he uninstalled 7M2 because of annoying bug: idea automatically changes struts-config.xml. idea deletes some lines

now i install idea 7M2 to myself
and it's green

so sorry for bothering you

0

Please sign in to leave a comment.