Having Problems with IDEA on Mac OS X

I recently started trying to moving from Windows platform on to my new Mac for development. However, I'm having lots of trouble with IDEA 6.0.5 on Mac. I'm having problems compiling under IDEA. I have a library that I wrote which uses annotations, and I keep getting an unexpected error in the complier saying it can't find that class. I recompiled that jar on the mac and tried again, but it still won't find the class. So, to work around the problem I compiled it manually with ant 1.7.0 outside of IDEA and it worked. I then went back into IDEA to try and run my program, but it fails to load the application saying bad class format. I'm using 1.5.0_07 for Mac, on Mac OS X 10.4.9. I'm using the same version of JDK in IDEA too. Any help?

Charlie

1 comment
Comment actions Permalink

Hey Charlie. Any examples of what types of annotations your using? Perhaps a verbatim error? Code examples of what is broken might be helpful. I'm on the same Mac and IDEA rev's so I can try to see if I can duplicate it if you have an example.

0

Please sign in to leave a comment.