How to disable xml parsing

Hi,
in our project, we have some large xml files (100 MB). When we add these files to the project, IDEA (6.0.5) parses them, and takes up a lot of memory (1 GB).

Is there any way to tell IDEA not to parse these files? We tried the "exclude folder" project setting, but then they were excluded from version control as well, and we still want to have them in svn.

Thanks in advance!

3 comments

Is there any notable difference when you disable all XML related inspections? (Use "xml" as search string in the inspection settings - there are quite a few of them around.)

Good luck and best regards,
Jens

0

If the above suggestion does not improve CPU usage, you might try and re-map the file type with extension ".xml" from "XML file" to "Text file".

Of course, then you won't have any of the goodies like highlighting, folding, element navigation, structure view, commenting out etc., but it should get rid of the XML parsing completely.

Regards,
Jens

0

Hi,
thanks for your suggestions! In the end, we just gzipped the xml files. They can be read by java still, but idea doesnt parse them.

cheers,
Ola

0

Please sign in to leave a comment.