Cannot remote debug in Ubuntu and Cacho Resin 3.x

Hi, I recently switched to Ubuntu 7.04, and I can no longer debug in Resin 3.1.1. I'm not sure if the problem lies with resin or intellij. I could debug under windows fine, and I can also debug with Resin 2.x fine under Ubuntu. I can connect to port 5005 (added the default line in my debug profile) ok, but my breakpoint never hit. I've seen classpath problems in the past where the red dot turns to an X, but this time I get nothing at all, it just skips all the breakpoints. I have another developer with the same issue on Intellij 6 w/Fedora core 5 as well. Debugging under resin 2.x seems fine for both of us.

Ryan

1 comment

Got this resolved after talking with the Caucho folks. For those migrating from Resin 2.x to 3.x, the debug parameters are no longer put on the resin command line, instead they now go in the blocks under the ]]> block in resin.conf. Same goes for other JVM settings.

Ryan

0

Please sign in to leave a comment.